aboutsummaryrefslogtreecommitdiff
path: root/distro
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2012-11-25 17:41:21 +0000
committerLudovic Courtès <ludo@gnu.org>2012-11-25 22:42:34 +0100
commitb147f59f41fdd6c3bc88a413b7ef2e0f3d39b19a (patch)
treeaad92c7216dcfd31101d2fcc0de895a3c8b650a5 /distro
parent6e6979c6f12c77e7306ed664e091de1c8f4201d4 (diff)
downloadguix-b147f59f41fdd6c3bc88a413b7ef2e0f3d39b19a.tar
guix-b147f59f41fdd6c3bc88a413b7ef2e0f3d39b19a.tar.gz
distro: Add GNU Time.
* distro/packages/time.scm: New file. * Makefile.am (MODULES): Add it.
Diffstat (limited to 'distro')
-rw-r--r--distro/packages/time.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/distro/packages/time.scm b/distro/packages/time.scm
new file mode 100644
index 0000000000..ec510222c1
--- /dev/null
+++ b/distro/packages/time.scm
@@ -0,0 +1,53 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages time)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public time
+ (package
+ (name "time")
+ (version "1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/time/time-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0va9063fcn7xykv658v2s9gilj2fq4rcdxx2mn2mmy1v4ndafzp3"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.gnu.org/software/time/")
+ (synopsis
+ "GNU Time, a tool that runs programs and summarizes the system
+resources they use")
+ (description
+ "The 'time' command runs another program, then displays information
+about the resources used by that program, collected by the system while
+the program was running. You can select which information is reported
+and the format in which it is shown, or have 'time' save the information
+in a file instead of displaying it on the screen.
+
+The resources that 'time' can report on fall into the general categories
+of time, memory, and I/O and IPC calls. Some systems do not provide
+much information about program resource use; 'time' reports unavailable
+information as zero values.
+")
+ (license "GPLv2+"))) \ No newline at end of file