aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-09-11 14:54:29 +0200
committerLudovic Courtès <ludo@gnu.org>2023-09-26 17:36:58 +0200
commitf651a359691cbe4750f1fe8d14dd964f7971f916 (patch)
tree37461ac136692991b66342b0678b57efa71af441 /configure.ac
parent95f21231352b66f92c466cb30f2258291e854f2f (diff)
downloadguix-f651a359691cbe4750f1fe8d14dd964f7971f916.tar
guix-f651a359691cbe4750f1fe8d14dd964f7971f916.tar.gz
build: Add dependency on Git.
* configure.ac: Check for ‘git’ and substitute ‘GIT’. * guix/config.scm.in (%git): New variable. * guix/self.scm (compiled-guix): Define ‘git’ and pass it to ‘make-config.scm’. (make-config.scm): Add #:git; emit a ‘%git’ variable. * doc/guix.texi (Requirements): Add it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 92dede8014..d817f620cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -201,6 +201,13 @@ AC_SUBST([GZIP])
AC_SUBST([BZIP2])
AC_SUBST([XZ])
+dnl Git is now required for the "builtin:git-download" derivation builder.
+AC_PATH_PROG([GIT], [git])
+if test "x$GIT" = "x"; then
+ AC_MSG_ERROR([Git is missing; please install it.])
+fi
+AC_SUBST([GIT])
+
LIBGCRYPT_LIBDIR="no"
LIBGCRYPT_PREFIX="no"