aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-22 22:18:16 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-23 23:39:33 -0400
commitee990899bd54e5c7c9193a75b8f713831b979e9f (patch)
tree023077c4e3ac32421154168d15aa20659d9f1e5c /configure.ac
parent8b5339acfe381dca887b38634dcfdecae738ce7b (diff)
downloadguix-ee990899bd54e5c7c9193a75b8f713831b979e9f.tar
guix-ee990899bd54e5c7c9193a75b8f713831b979e9f.tar.gz
build: Add a check for Guile-Lib.
* configure.ac: Check if the Guile-Lib module is present and recent enough and warn in case it isn't.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1598bfae94..7c1b9ef8dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,6 +150,13 @@ if test "x$guix_cv_have_recent_guile_git" != "xyes"; then
AC_MSG_ERROR([A recent Guile-Git could not be found; please install it.])
fi
+dnl Check for the optional Guile-Lib.
+GUILE_MODULE_EXPORTS([have_guile_lib], [(htmlprag)], [%strict-tokenizer?])
+AM_CONDITIONAL([HAVE_GUILE_LIB], [test "x$have_guile_lib" = "xyes"])
+AM_COND_IF(HAVE_GUILE_LIB,,
+ [AC_MSG_WARN([The Guile-Lib requirement was not satisfied (>= 0.2.7);
+Some features such as the Go importer will not be usable.])])
+
dnl Check for Guile-zlib.
GUIX_CHECK_GUILE_ZLIB
if test "x$guix_cv_have_recent_guile_zlib" != "xyes"; then