aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-09 23:44:14 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-09 23:44:14 +0200
commitee3e157dec3512778502f20538c581f5e28d63fe (patch)
treef1089216e0920f4c603ca38a2417c9133eac38c1 /configure.ac
parentc833ab556f811da6d1d9e467cb85b36e5d006cc7 (diff)
downloadguix-ee3e157dec3512778502f20538c581f5e28d63fe.tar
guix-ee3e157dec3512778502f20538c581f5e28d63fe.tar.gz
Add Bash completion file.
* etc/completion/bash/guix: New file. * Makefile.am (dist_bashcompletion_DATA): New variable. * configure.ac: Add --with-bash-completion-dir.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6f261cdb63..2227c71c1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,13 @@ AC_ARG_WITH(store-dir,
[storedir="/gnu/store"])
AC_SUBST(storedir)
+AC_ARG_WITH([bash-completion-dir],
+ AC_HELP_STRING([--with-bash-completion-dir=DIR],
+ [name of the Bash completion directory]),
+ [bashcompletiondir="$withval"],
+ [bashcompletiondir='${sysconfdir}/bash_completion.d'])
+AC_SUBST([bashcompletiondir])
+
dnl Better be verbose.
AC_MSG_CHECKING([for the store directory])
AC_MSG_RESULT([$storedir])