aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-03-11 16:13:03 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-11 18:42:09 +0100
commite688c2df3924423b67892cc9939ca099c729d1cb (patch)
tree56beea411f3986e86b3be1ce22f3f3dfe7622329 /configure.ac
parent3c1ea8dcef3342dba9fb1456effb31eb106a189a (diff)
downloadguix-e688c2df3924423b67892cc9939ca099c729d1cb.tar
guix-e688c2df3924423b67892cc9939ca099c729d1cb.tar.gz
build: Require Guile 2.2.3 or later.
* configure.ac: For 2.2.x, require 2.2.3 or later.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 06e86c209f..6a6a020585 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,7 +96,11 @@ dnl 'GUILE_EFFECTIVE_VERSION'.
GUILE_PKG([3.0 2.2])
GUILE_PROGS
if test "x$GUILD" = "x"; then
- AC_MSG_ERROR(['guild' binary not found; please check your guile-2.x installation.])
+ AC_MSG_ERROR(['guild' binary not found; please check your Guile installation.])
+fi
+
+if test "x$GUILE_EFFECTIVE_VERSION" = "x2.2"; then
+ PKG_CHECK_MODULES([GUILE], [guile-2.2 >= 2.2.3])
fi
dnl Installation directories for .scm and .go files.