aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-03-31 00:12:01 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-05-14 23:05:42 -0400
commitcb21ae76714f1873d3b3fb40d5135f00ec104b85 (patch)
treee9dc974235e6ec25e3ddda6338a50a52c565e636 /configure.ac
parentb6d18fbdf6ab4a8821a58aa16587676e835001f2 (diff)
downloadguix-cb21ae76714f1873d3b3fb40d5135f00ec104b85.tar
guix-cb21ae76714f1873d3b3fb40d5135f00ec104b85.tar.gz
etc: indent-code.el: Use the --quick option.
This prevents Emacs from loading the autoload definitions found in its profile, which needlessly clutters the output. It also prevents Geiser (if installed) from blocking the script and asking the user to input the Scheme implementation to use. The trick for passing multiple arguments to Emacs is to use what is called a "sesquicolon" (see https://www.emacswiki.org/emacs/EmacsScripts). * etc/indent-code.el.in: Rename to... * etc/indent-code.el: ...this. Adapt the shebang to use a sesquicolon, and pass the --quick option to Emacs. Since this line is interpreted by the shell, simply use Emacs from the PATH instead of from a hard coded location. (main): New procedure, used as the entry point. * configure.ac: Remove the warning about Emacs. Emacs can now be installed any time by the user if they want to use the script. * .gitignore: No longer ignore changes to etc/indent-code.el.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index a44a605dc0..0a20b476eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -286,15 +286,6 @@ dnl Documentation translation.
AM_MISSING_PROG([PO4A_TRANSLATE], [po4a-translate])
AM_MISSING_PROG([PO4A_UPDATEPO], [po4a-updatepo])
-dnl Emacs (optional), for 'etc/indent-code.el'.
-AC_PATH_PROG([EMACS], [emacs])
-if test "x$EMACS" = x; then
- AC_MSG_WARN([Please install GNU Emacs to use etc/indent-code.el.])
-else
- AC_SUBST([EMACS])
- AC_CONFIG_FILES([etc/indent-code.el], [chmod +x etc/indent-code.el])
-fi
-
case "$storedir" in
/gnu/store)
;;