aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2019-11-07 19:27:25 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-09 00:36:53 +0100
commitc8364ebca82f39fc10ca8b578584b7d1ff546cb1 (patch)
tree1aa02c4d2409006f41b1d555ee52bff6dfcf40dc /configure.ac
parentc52555559a509dc51b6ce31016e362af994ffc44 (diff)
downloadguix-c8364ebca82f39fc10ca8b578584b7d1ff546cb1.tar
guix-c8364ebca82f39fc10ca8b578584b7d1ff546cb1.tar.gz
build: Warn about etc/indent-code.el when Emacs is absent.
* configure.ac: Warn when 'emacs' is not found, and emit 'etc/indent-code.el' otherwise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 689b28d984..69ab9a97b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -280,9 +280,14 @@ dnl Documentation translation.
AM_MISSING_PROG([PO4A_TRANSLATE], [po4a-translate])
AM_MISSING_PROG([PO4A_UPDATEPO], [po4a-updatepo])
-dnl Emacs (optional), for 'etc/indent-package.el'.
-AC_PATH_PROG([EMACS], [emacs], [/usr/bin/emacs])
-AC_SUBST([EMACS])
+dnl Emacs (optional), for 'etc/indent-code.el'.
+AC_PATH_PROG([EMACS], [emacs])
+if test "x$EMACS" = x; then
+ AC_MSG_WARN([Please install GNU Emacs to use etc/indent-code.el.])
+else
+ AC_SUBST([EMACS])
+ AC_CONFIG_FILES([etc/indent-code.el], [chmod +x etc/indent-code.el])
+fi
case "$storedir" in
/gnu/store)
@@ -302,6 +307,5 @@ AC_CONFIG_FILES([Makefile
AC_CONFIG_FILES([test-env:build-aux/test-env.in], [chmod +x test-env])
AC_CONFIG_FILES([pre-inst-env:build-aux/pre-inst-env.in],
[chmod +x pre-inst-env])
-AC_CONFIG_FILES([etc/indent-code.el], [chmod +x etc/indent-code.el])
AC_OUTPUT