aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2018-12-01 20:46:22 -0600
committerEric Bavier <bavier@member.fsf.org>2018-12-02 17:56:05 -0600
commit6776af04d4b65c5a9a07784307a6abe395b6f480 (patch)
tree24bc82ab725e14ce7f39d6fef7c36601ce55ae8e /configure.ac
parenta7bed894d2dca20071a4738e4fd604bd8b7cf1a3 (diff)
downloadguix-6776af04d4b65c5a9a07784307a6abe395b6f480.tar
guix-6776af04d4b65c5a9a07784307a6abe395b6f480.tar.gz
Make Guile-JSON a required dependency.
* README (Requirements): Remove "optional" verbiage. * doc/guix.texi (Requirements): Move Guile-JSON from optional to required. * configure.ac (HAVE_GUILE_JSON): Remove Automake conditional. (have_guile_json): Error if not "yes". * Makefile.am (MODULE, SCM_TESTS)[HAVE_GUILE_JSON]: Add modules and tests unconditionally. * gnu/packages/package-mangement.scm (guix-minimal)[propagated-inputs]: Leave guile-json input.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2a1edbc321..2817e6e24d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,9 +122,11 @@ if test "x$have_guile_git" != "xyes"; then
AC_MSG_ERROR([Guile-Git is missing; please install it.])
fi
-dnl Guile-JSON is used in various places.
+dnl Check for Guile-JSON.
GUILE_MODULE_AVAILABLE([have_guile_json], [(json)])
-AM_CONDITIONAL([HAVE_GUILE_JSON], [test "x$have_guile_json" = "xyes"])
+if test "x$have_guile_json" != "xyes"; then
+ AC_MSG_ERROR([Guile-JSON is missing; please install it.])
+fi
dnl Guile-Sqlite3 is used by the (guix store ...) modules.
GUIX_CHECK_GUILE_SQLITE3