aboutsummaryrefslogtreecommitdiff
path: root/config-daemon.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-04-02 10:44:20 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-03 22:44:39 +0200
commitf65cf81a3cd15eab993e129977bca46972508b4b (patch)
tree81fea5351de590e66a985870f02aeb85bf33a3fc /config-daemon.ac
parentcf53ecf514301d3ffdfc33dea057b057ffb132d6 (diff)
downloadguix-f65cf81a3cd15eab993e129977bca46972508b4b.tar
guix-f65cf81a3cd15eab993e129977bca46972508b4b.tar.gz
Add preliminary binary substituter.
* guix/scripts/substitute-binary.scm: New file. * Makefile.am (MODULES): Add it. * nix/scripts/substitute-binary.in: New file. * config-daemon.ac: Produce nix/scripts/substitute-binary. * daemon.am (nodist_pkglibexec_SCRIPTS): Add nix/scripts/substitute-binary. * guix/store.scm (substitutable-path-info): Use the `query-substitutable-path-infos' RPC. * nix/nix-daemon/guix-daemon.cc (main): Honor `NIX_SUBSTITUTERS'. * pre-inst-env.in: Set `NIX_SUBSTITUTERS'. * test-env.in: Leave `NIX_SUBSTITUTERS' unchanged. Set `GUIX_BINARY_SUBSTITUTE_URL, and create $NIX_STATE_DIR/substituter-data. Run `guix-daemon' within `./pre-inst-env'. * tests/store.scm ("substitute query"): New test.
Diffstat (limited to 'config-daemon.ac')
-rw-r--r--config-daemon.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/config-daemon.ac b/config-daemon.ac
index f48741dfda..eed1e23f9e 100644
--- a/config-daemon.ac
+++ b/config-daemon.ac
@@ -93,8 +93,9 @@ if test "x$guix_build_daemon" = "xyes"; then
AC_MSG_RESULT([$GUIX_TEST_ROOT])
AC_SUBST([GUIX_TEST_ROOT])
- AC_CONFIG_FILES([nix/scripts/list-runtime-roots],
- [chmod +x nix/scripts/list-runtime-roots])
+ AC_CONFIG_FILES([nix/scripts/list-runtime-roots
+ nix/scripts/substitute-binary],
+ [chmod +x nix/scripts/list-runtime-roots nix/scripts/substitute-binary])
fi
AM_CONDITIONAL([BUILD_DAEMON], [test "x$guix_build_daemon" = "xyes"])