aboutsummaryrefslogtreecommitdiff
path: root/config-daemon.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-05-12 23:26:46 +0200
committerLudovic Courtès <ludo@gnu.org>2013-05-12 23:26:46 +0200
commite8b3afeb9234bca4a455272a6a831d7994d29b96 (patch)
treebc08b6b2d8d8c518927a220079c2b62253dd58fa /config-daemon.ac
parentf5ebf5c6ac2b9c48608211349acf1b4119a6f8c1 (diff)
downloadguix-e8b3afeb9234bca4a455272a6a831d7994d29b96.tar
guix-e8b3afeb9234bca4a455272a6a831d7994d29b96.tar.gz
build: Use separate `AC_CONFIG_FILES' invocations for executable files.
* configure.ac: Use separate AC_CONFIG_FILES invocations for files that need to be made executable. * config-daemon.ac: Likewise.
Diffstat (limited to 'config-daemon.ac')
-rw-r--r--config-daemon.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/config-daemon.ac b/config-daemon.ac
index 7c51f2b95c..5db08d099d 100644
--- a/config-daemon.ac
+++ b/config-daemon.ac
@@ -101,9 +101,10 @@ if test "x$guix_build_daemon" = "xyes"; then
AC_MSG_RESULT([$GUIX_TEST_ROOT])
AC_SUBST([GUIX_TEST_ROOT])
- AC_CONFIG_FILES([nix/scripts/list-runtime-roots
- nix/scripts/substitute-binary],
- [chmod +x nix/scripts/list-runtime-roots nix/scripts/substitute-binary])
+ AC_CONFIG_FILES([nix/scripts/list-runtime-roots],
+ [chmod +x nix/scripts/list-runtime-roots])
+ AC_CONFIG_FILES([nix/scripts/substitute-binary],
+ [chmod +x nix/scripts/substitute-binary])
fi
AM_CONDITIONAL([BUILD_DAEMON], [test "x$guix_build_daemon" = "xyes"])