aboutsummaryrefslogtreecommitdiff
path: root/config-daemon.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-06 00:03:26 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-06 00:07:08 +0100
commit69cfce50dbb2000c5f5d98f0f364fe324004bf99 (patch)
treeceb925ad7fa3f30b88c6074a071a229a31f769eb /config-daemon.ac
parentb980f0f9fd6f926f2a1130f77bd3cdb70e741429 (diff)
downloadguix-69cfce50dbb2000c5f5d98f0f364fe324004bf99.tar
guix-69cfce50dbb2000c5f5d98f0f364fe324004bf99.tar.gz
build: Run all the tests against the just-built daemon.
* test-env.in: New file. * configure.ac: Add it to `AC_CONFIG_FILES' and `commands-exec'. * config-daemon.ac: Set and substitute `GUIX_TEST_ROOT'. * Makefile.am (SCM_LOG_COMPILER, SH_LOG_COMPILER): Use it in lieu of `pre-inst-env'. * daemon.am (test_root): Remove (AM_TESTS_ENVIRONMENT): Remove `TEST_ROOT'. (clean-local): Use $(GUIX_TEST_ROOT); make files writable before removing them.guix_test_root * tests/guix-daemon.sh: Remove `NIX_' variable settings; don't launch `guix-daemon'.
Diffstat (limited to 'config-daemon.ac')
-rw-r--r--config-daemon.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/config-daemon.ac b/config-daemon.ac
index 946f6e453d..edd372fba9 100644
--- a/config-daemon.ac
+++ b/config-daemon.ac
@@ -92,6 +92,12 @@ if test "x$guix_build_daemon" = "xyes"; then
dnl Check for <linux/fs.h> (for immutable file support).
AC_CHECK_HEADERS([linux/fs.h])
+ dnl Temporary directory used to store the daemon's data.
+ AC_MSG_CHECKING([for unit test root])
+ GUIX_TEST_ROOT="`pwd`/test-tmp"
+ AC_MSG_RESULT([$GUIX_TEST_ROOT])
+ AC_SUBST([GUIX_TEST_ROOT])
+
AC_CONFIG_FILES([nix/scripts/list-runtime-roots],
[chmod +x nix/scripts/list-runtime-roots])
fi