aboutsummaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-14 23:29:26 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-14 23:29:26 +0200
commit8bc35f85b75d9cf6b8d0d95f8dd25600f3d272c4 (patch)
treedf33d0361679466d3417afaf7774493130c9d2e5 /build-aux
parentb6075935338f59719efe39667a495011817292b3 (diff)
downloadguix-8bc35f85b75d9cf6b8d0d95f8dd25600f3d272c4.tar
guix-8bc35f85b75d9cf6b8d0d95f8dd25600f3d272c4.tar.gz
build: Add missing 'make-binary-tarball.scm' script.
This script is used by the target added in 9d3fb6c. * build-aux/make-binary-tarball.scm: New file. * Makefile.am (EXTRA_DIST): Add it.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/make-binary-tarball.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/build-aux/make-binary-tarball.scm b/build-aux/make-binary-tarball.scm
new file mode 100644
index 0000000000..0b5dbaf1de
--- /dev/null
+++ b/build-aux/make-binary-tarball.scm
@@ -0,0 +1,50 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+
+;;;
+;;; Build a self-contained tarball containing binaries for Guix and its
+;;; dependencies.
+;;;
+
+(use-modules (guix)
+ (guix ui)
+ (gnu system install)
+ (ice-9 match))
+
+(define show-what-to-build*
+ (store-lift show-what-to-build))
+
+(define copy-file*
+ (lift2 copy-file %store-monad))
+
+(define rename-file*
+ (lift2 rename-file %store-monad))
+
+(match (command-line)
+ ((_ system file)
+ (with-store store
+ (run-with-store store
+ (mlet %store-monad ((tarball (self-contained-tarball)))
+ (mbegin %store-monad
+ (show-what-to-build* (list tarball))
+ (built-derivations (list tarball))
+ (copy-file* (derivation->output-path tarball)
+ (string-append file ".part"))
+ (rename-file* (string-append file ".part") file)))
+ #:system system))))