aboutsummaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-08-21 10:43:43 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-08-21 10:45:45 +0200
commit3c6b6941a2c76c26ebf0c1bfd7f901a22c19dce1 (patch)
treea8a0bb0afd6fee0744a48d368f7cd423c9f76524 /build-aux
parent7cad70566322262f6acdbbb965e867e34010eb55 (diff)
downloadguix-3c6b6941a2c76c26ebf0c1bfd7f901a22c19dce1.tar
guix-3c6b6941a2c76c26ebf0c1bfd7f901a22c19dce1.tar.gz
maint: Add 'etc/hurd-manifest.scm'.
* build-aux/cuirass/hurd-manifest.scm: Move to... * etc/hurd-manifest.scm: ...here. * Makefile.am (EXTRA_DIST): Update accordingly.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/cuirass/hurd-manifest.scm77
1 files changed, 0 insertions, 77 deletions
diff --git a/build-aux/cuirass/hurd-manifest.scm b/build-aux/cuirass/hurd-manifest.scm
deleted file mode 100644
index 1b1d0a53b4..0000000000
--- a/build-aux/cuirass/hurd-manifest.scm
+++ /dev/null
@@ -1,77 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-;;; Commentary:
-;;;
-;;; This file defines a manifest with a selection of packages for Cuirass to
-;;; build for GNU/Hurd.
-;;;
-;;; Code:
-
-(use-modules (gnu)
- (gnu system hurd)
- (guix packages)
- (guix utils)
- (ice-9 match)
- (srfi srfi-1))
-
-(use-package-modules
- base bootloaders commencement compression file gawk gdb gettext guile
- hurd less m4 package-management python ssh version-control)
-
-(define (input->package input)
- "Return the INPUT as package, or #f."
- (match input
- ((label (and (? package?) package))
- package)
- ((label (and (? package?) package . output))
- (cons package output))
- (_ #f)))
-
-(define guix-dependencies
- (filter-map input->package
- (fold alist-delete (package-direct-inputs guix)
- '("glibc-utf8-locales" "graphviz" "po4a"))))
-
-(define (package-without-tests p)
- (package/inherit p
- (arguments
- (substitute-keyword-arguments (package-arguments p)
- ((#:tests? _ #f) #f)))))
-
-(packages->manifest
- (cons*
- ;; where it all starts
- hello
-
- ;; development utililities
- diffutils file findutils gawk grep gzip less m4 openssh-sans-x tar xz
-
- ;; development packages
- gcc-toolchain gdb-minimal git-minimal gnu-make
- gettext-minimal python-minimal
-
- ;; ourselves!
- (package-without-tests guix)
-
- ;; system
- grub-minimal grub
-
- (append
- guix-dependencies
- %base-packages/hurd)))