aboutsummaryrefslogtreecommitdiff
path: root/bootstrap
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-04-14 09:42:25 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-04-19 16:45:41 +0200
commit2b8a2a6e723a0cf987c814865df9368e6348b6f8 (patch)
treef735021713cf8b64d13bfd4cab171510d32b0ce7 /bootstrap
parenta47f2288615099d7cc25f833a0e9a60b27c4ea79 (diff)
downloadguix-2b8a2a6e723a0cf987c814865df9368e6348b6f8.tar
guix-2b8a2a6e723a0cf987c814865df9368e6348b6f8.tar.gz
maint: Generate doc/version[-LANG].texi using `mdate-from-git.scm'.
This replaces Automake's `build-aux/mdate-sh' with our own `build-aux/mdate-from-git.scm' to use reproducible timestamps from Git instead. * build-aux/mdate-from-git.scm: New script. * bootstrap: Use it to replace build-aux/mdate-sh. * Makefile.am (EXTRA_DIST): Add it. Change-Id: I17d0a7de9ffea397129c0db1728f86e28a4e245f
Diffstat (limited to 'bootstrap')
-rwxr-xr-xbootstrap8
1 files changed, 7 insertions, 1 deletions
diff --git a/bootstrap b/bootstrap
index de024aeaa5..5bf83175e5 100755
--- a/bootstrap
+++ b/bootstrap
@@ -24,4 +24,10 @@ for lang in ${langs}; do
fi
done
-exec autoreconf -vfi
+autoreconf -vfi
+
+# Replace Automake's build-aux/mdate-sh with build-aux/mdate-from-git, our
+# own, reproducible version.
+chmod +w build-aux/mdate-sh
+rm -f build-aux/mdate-sh
+ln -s mdate-from-git.scm build-aux/mdate-sh