aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-04 09:45:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-06 23:21:11 -0400
commited0f0204b2c901be006a8441ea4d392a89aba77e (patch)
tree30209f08c73e33151c9fbc502b284492709a8aed /Makefile.am
parent8af2865896ddc130df08af2b17b77adc2dd7d81a (diff)
downloadguix-ed0f0204b2c901be006a8441ea4d392a89aba77e.tar
guix-ed0f0204b2c901be006a8441ea4d392a89aba77e.tar.gz
Makefile.am: Only auto-configure Git when available.
* Makefile.am (.git/hooks/pre-push): Only run recipe if the '.git' directory exists. Make it silent. (.git/config): Likewise, and also check if the 'git' command is available. Reported-by: Brian Cully <bjc@spork.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b71109ca18..8af69f88ac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1115,10 +1115,14 @@ cuirass-jobs: $(GOBJECTS)
# Git auto-configuration.
.git/hooks/pre-push: etc/git/pre-push
- -cp etc/git/pre-push .git/hooks/pre-push
+ $(AM_V_at)if test -d .git; then \
+ cp etc/git/pre-push .git/hooks/pre-push; \
+ fi
.git/config: etc/git/gitconfig
- -git config include.path ../etc/git/gitconfig
+ $(AM_V_at)if command -v git >/dev/null && test -d .git; then \
+ git config include.path ../etc/git/gitconfig; \
+ fi
nodist_noinst_DATA = .git/hooks/pre-push .git/config