aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-08-11 17:15:27 +0200
committerLudovic Courtès <ludo@gnu.org>2014-08-11 17:49:45 +0200
commitebc32b311088808d028804909c841154e5c8bc9f (patch)
tree3b131aba89120129973f3ec91fc3231fa75fce8d /Makefile.am
parent8991a470ea2881635c8a1c352f2552aab87a9f92 (diff)
downloadguix-ebc32b311088808d028804909c841154e5c8bc9f.tar
guix-ebc32b311088808d028804909c841154e5c8bc9f.tar.gz
build: 'make clean' doesn't delete os-config.tmpl.
Fixes <http://bugs.gnu.org/18243>. Reported by Andreas Enge and Mark H. Weaver. * Makefile.am (EXAMPLES): New variable. (nobase_dist_guilemodule_DATA): Add it. * gnu-system.am (GNU_SYSTEM_MODULES): Remove gnu/system/os-config.tmpl.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ed11bcc7ac..6695e7e5b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -107,9 +107,13 @@ KCONFIGS = \
gnu/packages/linux-libre-i686.conf \
gnu/packages/linux-libre-x86_64.conf
+# Templates, examples.
+EXAMPLES = \
+ gnu/system/os-config.tmpl
+
GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go
-nobase_dist_guilemodule_DATA = $(MODULES) $(KCONFIGS)
+nobase_dist_guilemodule_DATA = $(MODULES) $(KCONFIGS) $(EXAMPLES)
nobase_nodist_guilemodule_DATA = $(GOBJECTS) guix/config.scm
# Do we need to provide our own non-broken (srfi srfi-37) module?