aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMekeor Melire <mekeor@posteo.de>2023-05-07 10:43:41 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-07 09:12:47 -0400
commit7f8575c97a8c112e9f82981b8803d075a82738dd (patch)
tree13c079e336cd7d84360135aae0d82ea0699a2146 /Makefile.am
parent8b855dc1f4a3e31c002c229ad4d91525f4ce97d3 (diff)
downloadguix-7f8575c97a8c112e9f82981b8803d075a82738dd.tar
guix-7f8575c97a8c112e9f82981b8803d075a82738dd.tar.gz
Makefile.am: Use --add flag to "git config".
Without the "--add" flag to "git config include.path ...", the command fails if the user already has a configuration entry of "include.path". Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8af69f88ac..13718e4353 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1121,7 +1121,7 @@ cuirass-jobs: $(GOBJECTS)
.git/config: etc/git/gitconfig
$(AM_V_at)if command -v git >/dev/null && test -d .git; then \
- git config include.path ../etc/git/gitconfig; \
+ git config --add include.path ../etc/git/gitconfig; \
fi
nodist_noinst_DATA = .git/hooks/pre-push .git/config