aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 18:00:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 20:35:15 -0400
commit75aba5a746aa34dcc8e29eb043fdafd2104f6639 (patch)
tree96d97453fdf42bd627be2cfb6681f40b46907c04 /Makefile.am
parent4cf4dcb8b31274a8dfba6bae3a6826a1b521da3f (diff)
downloadguix-75aba5a746aa34dcc8e29eb043fdafd2104f6639.tar
guix-75aba5a746aa34dcc8e29eb043fdafd2104f6639.tar.gz
build: Avoid git config 'include' duplicates.
* Makefile.am (.git/config): Invoke git config --replace-all with a value-pattern instead of --add. Change-Id: Id6e19b15d3772105128eb9b48d0f4e039ae3d988 Reported-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 96fb278029..34a725f534 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1167,7 +1167,8 @@ cuirass-jobs: $(GOBJECTS)
.git/config: etc/git/gitconfig
$(AM_V_at)if command -v git >/dev/null && test -d .git; then \
- git config --add include.path ../etc/git/gitconfig; \
+ git config --fixed-value --replace-all include.path \
+ ../etc/git/gitconfig ../etc/git/gitconfig;
fi
COMMIT_MSG_MAGIC = VGhpcyBpcyB0aGUgY29tbWl0LW1zZyBob29rIG9mIEd1aXg=