aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-11-25 16:17:33 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-03 08:26:03 +0100
commit5cb84f2013c5b1e48a7d0e617032266f1e6059e2 (patch)
tree86c752e8ca1ee8144c82afb7894cb5d90916cf98 /Makefile.am
parent2c700af42cbb17859a7d80807fef2000cab7f8ad (diff)
downloadguix-5cb84f2013c5b1e48a7d0e617032266f1e6059e2.tar
guix-5cb84f2013c5b1e48a7d0e617032266f1e6059e2.tar.gz
system: Add "installer" sub-command.
* guix/scripts/system/installer.scm: New file. * Makefile.am (MODULES)[ENABLE_INSTALLER]: Register it. (MODULES_NOT_COMPILED)[!ENABLE_INSTALLER]: Likewise. * guix/scripts/system.scm (show-help): Add help for "installer" sub-command. (actions): Register "installer". (guix-system): Invoke `guix-system-installer' sub-command. * doc/guix.texi (Invoking guix system): Document it. * gnu/installer.scm (run-installer): Remove "./pre-inst env". Change-Id: I5a05b941c060682c17d45d871df3cf34e3f8643a
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0cff32c607..edbedd27f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -408,6 +408,14 @@ MODULES += \
endif BUILD_DAEMON_OFFLOAD
+INSTALLER_SCRIPT = guix/scripts/system/installer.scm
+
+if ENABLE_INSTALLER
+MODULES += $(INSTALLER_SCRIPT)
+else
+MODULES_NOT_COMPILED += $(INSTALLER_SCRIPT)
+endif !ENABLE_INSTALLER
+
# Scheme implementation of the build daemon and related functionality.
STORE_MODULES = \
guix/store/database.scm \