aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-02-22 22:42:03 +0000
committerChristopher Baines <mail@cbaines.net>2021-03-05 14:09:53 +0000
commit916209f51c743d260bcbe0b96454dea114e1d7d0 (patch)
treece7fe60efc73238432514704431faf64b3082704 /Makefile.am
parentc6c48494e318defbe28bcc6d37f28d59c30dbf32 (diff)
downloadguix-move-guix-scripts-substitute-code.tar
guix-move-guix-scripts-substitute-code.tar.gz
guix: Split (guix substitutes) from (guix scripts substitute).move-guix-scripts-substitute-code
This means there's a module for working with substitutes, rather than all the code sitting in the script. The need for this can be seen with the weather and challenge scripts, that now don't have to use code from the substitute script, but can instead use the substitute module. The separation here between the actual functionality of the substitute script and the underlying functionality used both there and elsewhere should make maintenance easier moving forward. This commit just moves code, none of the code should have been changed significantly. * guix/scripts/substitute.scm (%narinfo-cache-directory, %narinfo-ttl, %narinfo-negative-ttl, %narinfo-transient-error-ttl, %unreachable-hosts): Move variables to guix/substitutes.scm. (narinfo-cache-file, cached-narinfo, cache-narinfo!, narinfo-request, read-to-eof, call-with-connection-error-handling, fetch-narinfos, lookup-narinfos, lookup-narinfos/diverse): Move procedures to guix/substitutes.scm. * guix/substitutes.scm: New file. * Makefile.am: Add it. * guix/narinfo.scm: Remove redundant module. * guix/scripts/challenge.scm: Change (guix scripts substitute) to (guix substitutes). * guix/scripts/weather.scm: Change (guix scripts substitute) to (guix substitutes).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 394d2ef75e..bb27297096 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -114,6 +114,7 @@ MODULES = \
guix/channels.scm \
guix/gnu-maintenance.scm \
guix/self.scm \
+ guix/substitutes.scm \
guix/upstream.scm \
guix/licenses.scm \
guix/lint.scm \