aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-06 14:54:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-06 14:55:06 +0100
commitfe9bcf9db24e6f7849ad870e0853c251517fd6f0 (patch)
tree65e0b46798041f4f449616872f72b8fc332d51d6
parent760be95385765a9c19c710c2320b3ef584ef63c2 (diff)
downloadguix-fe9bcf9db24e6f7849ad870e0853c251517fd6f0.tar
guix-fe9bcf9db24e6f7849ad870e0853c251517fd6f0.tar.gz
gnu: Add r-plsdabatch.
* gnu/packages/bioinformatics.scm (r-plsdabatch): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0c1d6d38c7..0b1f36b347 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8669,6 +8669,46 @@ doublet-detection methods. In addition, this tool is used for execution and
benchmark of those eight mentioned methods.")
(license license:gpl3+))))
+(define-public r-plsdabatch
+ (let ((commit "4aadf3a99709afae462db310386b6cf5db20088c")
+ (revision "1"))
+ (package
+ (name "r-plsdabatch")
+ (version (git-version "0.2.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/EvaYiwenWang/PLSDAbatch")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "047l923lq2ji7rwybh9b9zkblzvvhkpli5gb2x8g2q9f2n5022nr"))))
+ (properties `((upstream-name . "PLSDAbatch")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ggplot2
+ r-ggpubr
+ r-gridextra
+ r-lmertest
+ r-mixomics
+ r-mvtnorm
+ r-performance
+ r-rdpack
+ r-scales))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/EvaYiwenWang/PLSDAbatch")
+ (synopsis "PLSDA-batch")
+ (description
+ "This package provides a new batch effect correction method based on
+Projection to Latent Structures Discriminant Analysis named “PLSDA-batch” to
+correct data prior to any downstream analysis. PLSDA-batch estimates latent
+components related to treatment and batch effects to remove batch variation.
+The method is multivariate, non-parametric and performs dimension reduction.
+Combined with centered log ratio transformation for addressing uneven library
+sizes and compositional structure, PLSDA-batch addresses all characteristics
+of microbiome data that existing correction methods have ignored so far.")
+ (license license:gpl3))))
+
(define-public r-psupertime
(let ((commit "73825a28d3bd9bc881c15ee0c4c218eec1c9c207")
(revision "1"))