aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-09-01 19:42:00 +0200
committerCyril Roelandt <tipecaml@gmail.com>2013-09-02 19:47:36 +0200
commitfbc1a58f4071c8a3ce2ac781b7cd363b8d21a364 (patch)
tree1114a476a847ea9e19c6ccd9f9db7cfccacab794
parent340c7033a89a81242f5e55e9fc1473a274dd9ad2 (diff)
downloadguix-fbc1a58f4071c8a3ce2ac781b7cd363b8d21a364.tar
guix-fbc1a58f4071c8a3ce2ac781b7cd363b8d21a364.tar.gz
gnu: Add dfc.
* gnu/packages/system.scm (dfc): New variable.
-rw-r--r--gnu/packages/system.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/system.scm b/gnu/packages/system.scm
index 2307393f85..7c733f9575 100644
--- a/gnu/packages/system.scm
+++ b/gnu/packages/system.scm
@@ -21,11 +21,34 @@
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages linux))
+(define-public dfc
+ (package
+ (name "dfc")
+ (version "3.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://projects.gw-computing.net/attachments/download/78/dfc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1b4hfqv23l87cb37fxwzfk2sgspkyxpr3ig2hsd23hr6mm982j7z"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ; There are no tests.
+ (home-page "http://projects.gw-computing.net/projects/dfc")
+ (synopsis "Display file system space usage using graphs and colors")
+ (description
+ "dfc (df color) is a modern version of df. It uses colors, draws pretty
+graphs and can export its output to different formats.")
+ (license bsd-3)))
+
(define-public htop
(package
(name "htop")