aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-14 09:23:01 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-14 09:24:27 +0800
commitfb3a390bea8bdde8c46e8eb22f07cec3dd026fe7 (patch)
treea4636e650401d26034346f363c844dc704a31664
parentfce2e41db4469575e26dd774614803c14c80c21e (diff)
downloadguix-fb3a390bea8bdde8c46e8eb22f07cec3dd026fe7.tar
guix-fb3a390bea8bdde8c46e8eb22f07cec3dd026fe7.tar.gz
gnu: vips: Fetch sources from git.
* gnu/packages/image-processing (vips)[source]: Fetch from git. Change-Id: I1bab0fdf3dd6c230025726c613f9eefb36238871
-rw-r--r--gnu/packages/image-processing.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 1a24837ac8..a79eaf6aed 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -781,12 +781,13 @@ the OpenCV-Python library.")
(version "8.15.3")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/libvips/libvips/releases/download/v"
- version "/vips-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libvips/libvips")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "182j20dw38f1nyfx8cf7cjsr0k4nl7lfk3wm2d0ddypa6vsxj9ry"))))
+ (base32 "0nxzhs4gwhpm4j9hlca8s97xh1b1p1cawnwdc69rmxkrf714hlgj"))))
(build-system meson-build-system)
(native-inputs
(list gobject-introspection pkg-config))