aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:12:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:30 +0200
commitfa6bfaf412b35e6cbabd6c14a37a4836678f066d (patch)
tree8336a2777e639deddc9dfc352112df036612e602
parent5d6c616d656351fcd49c6f33661555fa3e146af2 (diff)
downloadguix-fa6bfaf412b35e6cbabd6c14a37a4836678f066d.tar
guix-fa6bfaf412b35e6cbabd6c14a37a4836678f066d.tar.gz
gnu: Add texlive-pst-barcode.
* gnu/packages/tex.scm (texlive-pst-barcode): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ddb93593cd..05bbc433fc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -32490,6 +32490,30 @@ a comma-delimited file. Several types of bar charts may be drawn, and the
drawing parameters are highly customizable.")
(license license:lppl)))
+(define-public texlive-pst-barcode
+ (package
+ (name "texlive-pst-barcode")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-barcode/"
+ "dvips/pst-barcode/"
+ "tex/generic/pst-barcode/"
+ "tex/latex/pst-barcode/")
+ (base32
+ "10990hhhj961rizfffplx8v3rhnv7knm8nz2zd1aqp686fr3fkgv")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-barcode")
+ (synopsis "Print barcodes using PostScript")
+ (description
+ "The @code{pst-barcode} package allows printing of barcodes, in a huge
+variety of formats, including quick-response (QR) codes. As a PSTricks
+package, the package requires pstricks. The package uses @code{PostScript}
+for calculating the bars. For PDF output use a multi-pass mechansism such as
+@code{pst-pdf}.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")