aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-05 18:43:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-05 20:03:06 +0200
commitf9f4578ba0c4b5b22cdac86e8183dc542d66cc85 (patch)
tree812d937392969de8bcbdab4ee1f8cdc5aa823ab4
parent90708323a13c94bf36a56735da9c21a2203e9fde (diff)
downloadguix-f9f4578ba0c4b5b22cdac86e8183dc542d66cc85.tar
guix-f9f4578ba0c4b5b22cdac86e8183dc542d66cc85.tar.gz
Revert "gnu: ghc-tasty: Update to 1.1.0.3."
This reverts commit 3ad6b8909025a8f4d3e1f1f5ea16bcd0cace557c.
-rw-r--r--gnu/packages/haskell-check.scm7
-rw-r--r--gnu/packages/haskell.scm27
2 files changed, 6 insertions, 28 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 65333f8269..31407ca259 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -183,7 +183,7 @@ timer functions of different operating systems via a unified API.")
(define-public ghc-tasty
(package
(name "ghc-tasty")
- (version "1.1.0.3")
+ (version "0.11.0.4")
(source
(origin
(method url-fetch)
@@ -193,7 +193,7 @@ timer functions of different operating systems via a unified API.")
".tar.gz"))
(sha256
(base32
- "14riid753hjqr6lca1kgxpnvq0wykf0k3qc5jpag42hh8bszav22"))))
+ "05pxjzgbgjdn7477xry0ssjrnmnsydqiq6nm6ck8n2da1baliqp0"))))
(build-system haskell-build-system)
(inputs
`(("ghc-stm" ,ghc-stm)
@@ -205,8 +205,7 @@ timer functions of different operating systems via a unified API.")
("ghc-unbounded-delays" ,ghc-unbounded-delays)
("ghc-async" ,ghc-async)
("ghc-ansi-terminal" ,ghc-ansi-terminal)
- ("ghc-clock-bootstrap" ,ghc-clock-bootstrap)
- ("ghc-wcwidth" ,ghc-wcwidth)))
+ ("ghc-clock-bootstrap" ,ghc-clock-bootstrap)))
(home-page "http://documentup.com/feuerbach/tasty")
(synopsis "Modern and extensible testing framework")
(description "Tasty is a modern testing framework for Haskell. It lets
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 31a0d6d7ee..eb629cf138 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2870,7 +2870,7 @@ with slicing and Clang-style colored diagnostics.")
;; re-enable them.
(arguments `(#:tests? #f))
(inputs
- `(("ghc-scientific-bootstrap" ,ghc-scientific-bootstrap)
+ `(("ghc-scientific" ,ghc-scientific)
("ghc-text" ,ghc-text)))
(native-inputs
`(("ghc-tasty" ,ghc-tasty)
@@ -2885,13 +2885,6 @@ aimed particularly at dealing efficiently with network protocols and
complicated text/binary file formats.")
(license license:bsd-3)))
-(define ghc-attoparsec-bootstrap
- (package
- (inherit ghc-attoparsec)
- (name "ghc-attoparsec-bootstrap")
- (arguments '(#:tests? #f))
- (native-inputs '())))
-
(define-public ghc-zip-archive
(package
(name "ghc-zip-archive")
@@ -5221,13 +5214,6 @@ occurrences of a substring (the first in case of overlaps) with another.")
in migrated modules.")
(license license:expat)))
-(define ghc-integer-logarithms-bootstrap
- (package
- (inherit ghc-integer-logarithms)
- (name "ghc-integer-logarithms-bootstrap")
- (arguments `(#:tests? #f))
- (native-inputs '())))
-
(define-public ghc-scientific
(package
(name "ghc-scientific")
@@ -5244,7 +5230,7 @@ in migrated modules.")
"03ql2f0ac8bsl524idy9xxa3kxisb2sj3avflzw580j5hzy0m397"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-integer-logarithms-bootstrap" ,ghc-integer-logarithms-bootstrap)
+ `(("ghc-integer-logarithms" ,ghc-integer-logarithms)
("ghc-text" ,ghc-text)
("ghc-hashable" ,ghc-hashable)
("ghc-primitive" ,ghc-primitive)))
@@ -5265,13 +5251,6 @@ and space efficient. They are represented using
notation}.")
(license license:bsd-3)))
-(define ghc-scientific-bootstrap
- (package
- (inherit ghc-scientific)
- (name "ghc-scientific-bootstrap")
- (arguments `(#:tests? #f))
- (native-inputs '())))
-
(define-public ghc-boxes
(package
(name "ghc-boxes")
@@ -10195,7 +10174,7 @@ backends provided by the @code{Cairo} and @code{Diagrams} libraries.")
(inputs
`(("ghc-setlocale" ,ghc-setlocale)
("ghc-utf8-string" ,ghc-utf8-string)
- ("ghc-attoparsec-bootstrap" ,ghc-attoparsec-bootstrap)))
+ ("ghc-attoparsec" ,ghc-attoparsec)))
(home-page "https://github.com/solidsnack/wcwidth/")
(synopsis "Haskell bindings to wcwidth")
(description "This package provides Haskell bindings to your system's