aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-23 19:29:11 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-23 23:25:56 +0100
commitf882f62c6bdef79f0348f1cdfe7a727f44a9cc63 (patch)
tree34bebb9ea0b452040606a752cb7739e9154d6d18
parente54f0cf68067cbce0ad27baf52d48f968af100ec (diff)
downloadguix-f882f62c6bdef79f0348f1cdfe7a727f44a9cc63.tar
guix-f882f62c6bdef79f0348f1cdfe7a727f44a9cc63.tar.gz
gnu: python-pytest: Update to 4.3.1.
* gnu/packages/check.scm (python-pytest): Update to 4.3.1. [source](patches): Remove. * gnu/packages/patches/python-pytest-pluggy-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/check.scm5
-rw-r--r--gnu/packages/patches/python-pytest-pluggy-compat.patch64
3 files changed, 2 insertions, 68 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index e936343918..41f42e588f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1188,7 +1188,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-pycrypto-CVE-2013-7459.patch \
%D%/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
- %D%/packages/patches/python-pytest-pluggy-compat.patch \
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
%D%/packages/patches/python-unittest2-python3-compat.patch \
%D%/packages/patches/python-unittest2-remove-argparse.patch \
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 69fe278728..186f4ba09a 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -684,15 +684,14 @@ standard library.")
(define-public python-pytest
(package
(name "python-pytest")
- (version "4.3.0")
+ (version "4.3.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest" version))
- (patches (search-patches "python-pytest-pluggy-compat.patch"))
(sha256
(base32
- "077gzimi9xiiyzpc3xjpb5yfgz038xkldg91mmbdvzr7z15isyh6"))))
+ "08q58ad8vaxyb57ll8m611yb4xwzzhp09kxafmyqrrps6cnalbjr"))))
(build-system python-build-system)
(arguments
`(#:phases
diff --git a/gnu/packages/patches/python-pytest-pluggy-compat.patch b/gnu/packages/patches/python-pytest-pluggy-compat.patch
deleted file mode 100644
index ac33b862e6..0000000000
--- a/gnu/packages/patches/python-pytest-pluggy-compat.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-Fix test failures when built against Pluggy 0.9.
-
-Taken from this upstream commit:
-https://github.com/pytest-dev/pytest/commit/a68f4fd2b9e99c82476d0e04ebcf561aeddbcb2e
-
-diff --git a/testing/test_assertion.py b/testing/test_assertion.py
-index b659233eb..e4fe56c6f 100644
---- a/testing/test_assertion.py
-+++ b/testing/test_assertion.py
-@@ -209,7 +209,7 @@ def load(self, require=True, *args, **kwargs):
- import spamplugin
- return spamplugin
-
-- def iter_entry_points(name):
-+ def iter_entry_points(group, name=None):
- yield DummyEntryPoint()
-
- pkg_resources.iter_entry_points = iter_entry_points
-diff --git a/testing/test_config.py b/testing/test_config.py
-index f9f22a63e..1e29b83f1 100644
---- a/testing/test_config.py
-+++ b/testing/test_config.py
-@@ -514,8 +514,8 @@ def test_preparse_ordering_with_setuptools(testdir, monkeypatch):
- pkg_resources = pytest.importorskip("pkg_resources")
- monkeypatch.delenv("PYTEST_DISABLE_PLUGIN_AUTOLOAD", raising=False)
-
-- def my_iter(name):
-- assert name == "pytest11"
-+ def my_iter(group, name=None):
-+ assert group == "pytest11"
-
- class Dist(object):
- project_name = "spam"
-@@ -552,8 +552,8 @@ def test_setuptools_importerror_issue1479(testdir, monkeypatch):
- pkg_resources = pytest.importorskip("pkg_resources")
- monkeypatch.delenv("PYTEST_DISABLE_PLUGIN_AUTOLOAD", raising=False)
-
-- def my_iter(name):
-- assert name == "pytest11"
-+ def my_iter(group, name=None):
-+ assert group == "pytest11"
-
- class Dist(object):
- project_name = "spam"
-@@ -583,8 +583,8 @@ def test_plugin_preparse_prevents_setuptools_loading(testdir, monkeypatch, block
-
- plugin_module_placeholder = object()
-
-- def my_iter(name):
-- assert name == "pytest11"
-+ def my_iter(group, name=None):
-+ assert group == "pytest11"
-
- class Dist(object):
- project_name = "spam"
-@@ -621,7 +621,7 @@ def load(self):
- def test_disable_plugin_autoload(testdir, monkeypatch, parse_args, should_load):
- pkg_resources = pytest.importorskip("pkg_resources")
-
-- def my_iter(name):
-+ def my_iter(group, name=None):
- raise AssertionError("Should not be called")
-
- class PseudoPlugin(object):