aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-06 21:41:48 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-06 21:41:48 +0100
commitf8780e96ff9c4d1439f679aff0df559d97d673dc (patch)
tree4e0ecda0fd813b7eed8db4d606b8121b4887b9bd
parent3a08940e1a38d1f15630b6ad6678b1a79d70049d (diff)
downloadguix-f8780e96ff9c4d1439f679aff0df559d97d673dc.tar
guix-f8780e96ff9c4d1439f679aff0df559d97d673dc.tar.gz
gnu: r-org-dm-eg-db: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-org-dm-eg-db): Move from here... * gnu/packages/bioconductor.scm (r-org-dm-eg-db): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm26
-rw-r--r--gnu/packages/bioinformatics.scm26
2 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a55439b94e..f08e1a87c4 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -386,6 +386,32 @@ in Biostrings objects.")
annotations for the genome of the model worm Caenorhabditis elegans.")
(license license:artistic2.0)))
+(define-public r-org-dm-eg-db
+ (package
+ (name "r-org-dm-eg-db")
+ (version "3.7.0")
+ (source (origin
+ (method url-fetch)
+ ;; We cannot use bioconductor-uri here because this tarball is
+ ;; located under "data/annotation/" instead of "bioc/".
+ (uri (string-append "https://www.bioconductor.org/packages/"
+ "release/data/annotation/src/contrib/"
+ "org.Dm.eg.db_" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pqjrzlyg72bjpy8zsxvaglc7jsv176bnyi87xdajmkvsgxpm7b3"))))
+ (properties
+ `((upstream-name . "org.Dm.eg.db")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)))
+ (home-page "https://www.bioconductor.org/packages/org.Dm.eg.db/")
+ (synopsis "Genome wide annotation for Fly")
+ (description
+ "This package provides mappings from Entrez gene identifiers to various
+annotations for the genome of the model fruit fly Drosophila melanogaster.")
+ (license license:artistic2.0)))
+
(define-public r-org-dr-eg-db
(package
(name "r-org-dr-eg-db")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9285d1889d..0fffbf82d0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8006,32 +8006,6 @@ downloaded from Encode.")
on mapping using Entrez Gene identifiers.")
(license license:artistic2.0)))
-(define-public r-org-dm-eg-db
- (package
- (name "r-org-dm-eg-db")
- (version "3.7.0")
- (source (origin
- (method url-fetch)
- ;; We cannot use bioconductor-uri here because this tarball is
- ;; located under "data/annotation/" instead of "bioc/".
- (uri (string-append "https://www.bioconductor.org/packages/"
- "release/data/annotation/src/contrib/"
- "org.Dm.eg.db_" version ".tar.gz"))
- (sha256
- (base32
- "1pqjrzlyg72bjpy8zsxvaglc7jsv176bnyi87xdajmkvsgxpm7b3"))))
- (properties
- `((upstream-name . "org.Dm.eg.db")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-annotationdbi" ,r-annotationdbi)))
- (home-page "https://www.bioconductor.org/packages/org.Dm.eg.db/")
- (synopsis "Genome wide annotation for Fly")
- (description
- "This package provides mappings from Entrez gene identifiers to various
-annotations for the genome of the model fruit fly Drosophila melanogaster.")
- (license license:artistic2.0)))
-
(define-public r-org-mm-eg-db
(package
(name "r-org-mm-eg-db")