aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@posteo.net>2021-07-29 21:49:20 -0500
committerEric Bavier <bavier@posteo.net>2021-07-30 08:13:38 -0500
commitf71b91a22bc0d0c66866bb3f74f21768403a7e4e (patch)
treefe8b485b350c5d46c9a9d27a4f42918b3a5758f8
parent1484de9eff85b38e6b0b644e5db89da619d78a94 (diff)
downloadguix-f71b91a22bc0d0c66866bb3f74f21768403a7e4e.tar
guix-f71b91a22bc0d0c66866bb3f74f21768403a7e4e.tar.gz
gnu: Add python-pebble.
* gnu/packages/python-xyz.scm (python-pebble): New variable.
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 59cd7107bf..61db9febb8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7229,6 +7229,31 @@ The output of all running processes is collected by honcho and
displayed.")
(license license:expat)))
+(define-public python-pebble
+ (package
+ (name "python-pebble")
+ (version "4.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Pebble" version))
+ (sha256
+ (base32 "16siqc3brbk7dp4d9sg48bjl6a8wyy24aib3il1hf4y2624draxh"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ (invoke "python" "-m" "pytest" "-sv"))))))
+ (home-page "https://github.com/noxdafox/pebble")
+ (synopsis "Threading and multiprocessing for Python")
+ (description
+ "Pebble aims to help manage threads and processes in an easier way. It
+wraps Python's standard library threading and multiprocessing objects.")
+ (license license:lgpl3+)))
+
(define-public python-pexpect
(package
(name "python-pexpect")