aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-07 10:06:43 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-04-07 10:06:43 +0300
commitf6a62ce9ba3d63aa043560f8f5697e80bf1db728 (patch)
tree54c38028a0ed54eaf1436e2c54757b2bdfe6d2df
parent8ec53cabf24136cab354360b7536ba69424e8608 (diff)
downloadguix-f6a62ce9ba3d63aa043560f8f5697e80bf1db728.tar
guix-f6a62ce9ba3d63aa043560f8f5697e80bf1db728.tar.gz
gnu: quickjs: Update to 2024-01-13.
* gnu/packages/javascript.scm (quickjs): Update to 2024-01-13. [arguments]: Adjust make-flags to set PREFIX and not DESTDIR. [description]: Update with new features. Change-Id: I76189212c3baafda36b7327d47001147ffacb8a8
-rw-r--r--gnu/packages/javascript.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index 58092eca82..fba96b06a8 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -826,14 +826,14 @@ roots, or wrestle with obscure build systems.")
(define-public quickjs
(package
(name "quickjs")
- (version "2021-03-27")
+ (version "2024-01-13")
(source (origin
(method url-fetch)
(uri (string-append "https://bellard.org/quickjs/quickjs-"
version ".tar.xz"))
(sha256
(base32
- "06pywwpmfwjz225h59wf90q96a2fd66qfcw5xa6m6y9k9k7glnx4"))
+ "00rf45l1bx0yhlv11gn3bbyfqw9724c153bc93mlp9dzjpwghjrw"))
(snippet
#~(begin (use-modules (guix build utils))
(for-each delete-file
@@ -844,8 +844,7 @@ roots, or wrestle with obscure build systems.")
(build-system gnu-build-system)
(arguments
(list #:make-flags
- #~(list "prefix="
- (string-append "DESTDIR=" #$output)
+ #~(list (string-append "PREFIX=" #$output)
#$@(if (or (target-riscv64?)
(target-ppc32?))
'("LDFLAGS=-latomic")
@@ -858,11 +857,12 @@ roots, or wrestle with obscure build systems.")
(invoke "make" "microbench")))))))
(home-page "https://bellard.org/quickjs/")
(synopsis "Small embeddable Javascript engine")
- (description "QuickJS supports the ES2020 specification including modules,
-asynchronous generators, proxies, BigInt and BigDecimal. It can compile
-Javascript sources to executables with no external dependency. It includes a
-command line interpreter with contextual colorization implemented in
-Javascript and a small built-in standard library with C library wrappers.")
+ (description "QuickJS supports the ES2023 specification including modules,
+asynchronous generators, proxies, BigInt, BigDecimal, BigFloat and operator
+overloading. It can compile Javascript sources to executables with no external
+dependency. It includes a command line interpreter with contextual colorization
+implemented in Javascript and a small built-in standard library with C library
+wrappers.")
(license license:expat)))
(define-public duktape