aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-06-29 22:22:48 +0200
committerLudovic Courtès <ludo@gnu.org>2012-06-29 22:38:22 +0200
commitf68b089361ba768f1a9398225040af3e9faafbf3 (patch)
tree7a6afbfc672ea33fb7e278e1c758ab1b080ef182
parent64fddd74f0f1bb154149fcd8e6369a1be323c1d3 (diff)
downloadguix-f68b089361ba768f1a9398225040af3e9faafbf3.tar
guix-f68b089361ba768f1a9398225040af3e9faafbf3.tar.gz
Gettextize, with GNU Gettext 0.18.1.
* Makefile.am (EXTRA_DIST): Add `build-aux/config.rpath'. (SUBDIRS, ACLOCAL_AMFLAGS): New variables. * configure.ac: Use `AM_GNU_GETTEXT'. Emit `po/Makefile.in'. * po/Makevars, po/POTFILES.in: New files.
-rw-r--r--.gitignore22
-rw-r--r--Makefile.am6
-rw-r--r--configure.ac4
-rw-r--r--po/Makevars18
-rw-r--r--po/POTFILES.in2
5 files changed, 50 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
index a0331bcc5d..c6d6ad909b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -12,3 +12,25 @@ Makefile
config.cache
/aclocal.m4
/config.status
+/ABOUT-NLS
+/m4/ChangeLog
+/m4/gettext.m4
+/m4/iconv.m4
+/m4/lib-ld.m4
+/m4/lib-link.m4
+/m4/lib-prefix.m4
+/m4/nls.m4
+/m4/po.m4
+/m4/progtest.m4
+/po/ChangeLog
+/po/Makefile.in.in
+/po/POTFILES
+/po/Rules-quot
+/po/boldquot.sed
+/po/en@boldquot.header
+/po/en@quot.header
+/po/insert-header.sin
+/po/quot.sed
+/po/remove-potcdate.sin
+/po/stamp-po
+/po/guix.pot
diff --git a/Makefile.am b/Makefile.am
index 8b5713b1d9..af68ec82b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,7 +46,7 @@ TESTS_ENVIRONMENT = \
GUILE_LOAD_COMPILED_PATH="$(top_builddir):$$GUILE_LOAD_COMPILED_PATH" \
$(GUILE) -L "$(top_srcdir)"
-EXTRA_DIST = $(TESTS)
+EXTRA_DIST = build-aux/config.rpath $(TESTS)
CLEANFILES = $(GOBJECTS) *.log
.scm.go:
@@ -68,3 +68,7 @@ SUFFIXES = .go
# for details.
guix_install_go_files = install-nobase_nodist_guilemoduleDATA
$(guix_install_go_files): install-nobase_dist_guilemoduleDATA
+
+SUBDIRS = po
+
+ACLOCAL_AMFLAGS = -I m4
diff --git a/configure.ac b/configure.ac
index 1aabc24ab6..ca01e0bc6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,8 @@ AM_INIT_AUTOMAKE([1.11 foreign silent-rules subdir-objects \
AC_CONFIG_SRCDIR([guix.scm])
AC_CONFIG_MACRO_DIR([m4])
+AM_GNU_GETTEXT([external])
+
guilemoduledir="${datarootdir}/guile/site/2.0"
AC_SUBST([guilemoduledir])
@@ -51,6 +53,6 @@ else
AC_MSG_WARN([Please use `--with-nixpkgs'.])
fi
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile po/Makefile.in])
AC_OUTPUT
diff --git a/po/Makevars b/po/Makevars
new file mode 100644
index 0000000000..a57af08ea6
--- /dev/null
+++ b/po/Makevars
@@ -0,0 +1,18 @@
+# Makefile variables for PO directory in any package using GNU gettext.
+
+DOMAIN = $(PACKAGE)
+
+subdir = po
+top_builddir = ..
+
+# These options get passed to xgettext.
+XGETTEXT_OPTIONS = \
+ --language=Scheme \
+ --keyword=_ --keyword=N_ \
+ --keyword=description --keyword=long-description
+
+COPYRIGHT_HOLDER = Ludovic Courtès
+
+MSGID_BUGS_ADDRESS = ludo@gnu.org
+
+EXTRA_LOCALE_CATEGORIES =
diff --git a/po/POTFILES.in b/po/POTFILES.in
new file mode 100644
index 0000000000..39ff38db32
--- /dev/null
+++ b/po/POTFILES.in
@@ -0,0 +1,2 @@
+# List of source files which contain translatable strings.
+distro/base.scm