aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-07-16 01:10:09 +0000
committerjgart <jgart@dismail.de>2024-07-15 22:55:37 -0500
commitf4f79861e6b9dee45be0ee4164c0be0e414462a0 (patch)
treea92091e84f23f001c468ba5fa4ccdd6f123db675
parent1cab0165a9b16c975cc43bb69ec0dc85a28f2ad6 (diff)
downloadguix-f4f79861e6b9dee45be0ee4164c0be0e414462a0.tar
guix-f4f79861e6b9dee45be0ee4164c0be0e414462a0.tar.gz
gnu: Add python-pandapipes.
* gnu/packages/engineering.scm (python-pandapipes): New variable. Change-Id: I5858f8a82ec6b351e14a03ecc52a0b9fef62f7c0 Signed-off-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/engineering.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 6e204e6b6d..2875d45330 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2661,6 +2661,31 @@ Newton-Raphson power flow solvers in the C++ library lightsim2grid, and the
@code{PowerModels.jl} library.")
(license license:bsd-3)))
+(define-public python-pandapipes
+ (package
+ (name "python-pandapipes")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pandapipes" version ".zip"))
+ (sha256
+ (base32 "06yqqd25hxa6q49qcbpy0njwxkqzfhbff4frrrxd84391njgvdhq"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-nbmake
+ python-pytest
+ python-pytest-xdist
+ unzip))
+ (propagated-inputs (list python-matplotlib
+ python-pandapower
+ python-shapely))
+ (home-page "http://www.pandapipes.org")
+ (synopsis "Simulation of multi energy grids")
+ (description
+ "This package provides a pipeflow calculation tool that complements
+@code{pandapower} in the simulation of multi energy grids.")
+ (license license:bsd-3)))
+
(define-public python-scikit-rf
(package
(name "python-scikit-rf")