aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Goryachev via Guix-patches via <guix-patches@gnu.org>2024-08-05 13:44:35 +0300
committerAndrew Tropin <andrew@trop.in>2024-08-05 17:14:47 +0400
commitf44be566a58b4c57e79a8aab63cc7e798d9423e5 (patch)
tree1c8be7753b171cdfad397aeb63da238849d63040
parent7b4561b932d3114ca96ee5f54dfd5660a1ad9fb0 (diff)
downloadguix-f44be566a58b4c57e79a8aab63cc7e798d9423e5.tar
guix-f44be566a58b4c57e79a8aab63cc7e798d9423e5.tar.gz
gnu: Add erlang-jose.
* gnu/packages/erlang-xyz.scm (erlang-jose): New variable. Change-Id: I2f7bc3249098a2a36dcb42a4cf62ac15d03db533 Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/erlang-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 1cf5d9c6fd..862d9462a2 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -27,6 +27,25 @@
#:use-module (guix packages)
#:use-module (guix utils))
+(define-public erlang-jose
+ (package
+ (name "erlang-jose")
+ (version "1.11.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "jose" version))
+ (sha256
+ (base32 "0576jdjygby37qmzrs8cm5l6n622b0mi3z28j6r4s5xsz1px6v0d"))))
+ (build-system rebar-build-system)
+ (synopsis
+ "JSON Object Signing and Encryption for Erlang and Elixir")
+ (description
+ "This package provides JSON Object Signing and Encryption (JOSE) for
+Erlang and Elixir.")
+ (home-page "https://hex.pm/packages/jose")
+ (license license:expat)))
+
(define-public erlang-base64url
(package
(name "erlang-base64url")