aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-24 19:14:21 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:24 +0000
commitf23c46216a9272500517a4cabd76aec5185a65fa (patch)
treea26ed7d332f2f707ddff76f08240b765b0622c74
parent827a97b6e254745c20e96e2d5d6891e00d8f8d07 (diff)
downloadguix-f23c46216a9272500517a4cabd76aec5185a65fa.tar
guix-f23c46216a9272500517a4cabd76aec5185a65fa.tar.gz
gnu: sushi: Update to 3.38.1.
* gnu/packages/gnome.scm (sushi): Update to 3.38.1. [arguments]: Remove a trailing #t. [inputs]: Switch to gtksourceview. [description]: Wrap it.
-rw-r--r--gnu/packages/gnome.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d65c007932..88dfb8ead2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1577,7 +1577,7 @@ sharing to the masses.")
(define-public sushi
(package
(name "sushi")
- (version "3.32.1")
+ (version "3.38.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1585,7 +1585,7 @@ sharing to the masses.")
name "-" version ".tar.xz"))
(sha256
(base32
- "02idvqjk76lii9xyg3b1yz4rw721709bdm5j8ikjym6amcghl0aj"))))
+ "1sc8i0vrw6bn43rklnwp2fl1gq0r0xfd3bszcqxd0a2mh46d3rpk"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -1595,11 +1595,11 @@ sharing to the masses.")
(lambda* (#:key outputs #:allow-other-keys)
(let ((prog (string-append (assoc-ref outputs "out")
"/bin/sushi")))
- ;; Put existing typelibs before sushi's deps, so as to correctly
- ;; infer gdk-pixbuf
+ ;; Put existing typelibs before sushi's deps, so as to
+ ;; correctly infer gdk-pixbuf.
(wrap-program prog
- `("GI_TYPELIB_PATH" suffix (,(getenv "GI_TYPELIB_PATH"))))
- #t))))))
+ `("GI_TYPELIB_PATH" suffix
+ (,(getenv "GI_TYPELIB_PATH"))))))))))
(native-inputs
`(("glib:bin" ,glib "bin")
("gettext" ,gettext-minimal)
@@ -1615,7 +1615,7 @@ sharing to the masses.")
("gjs" ,gjs)
("gst-plugins-base" ,gst-plugins-base)
("gstreamer" ,gstreamer)
- ("gtksourceview" ,gtksourceview-3)
+ ("gtksourceview" ,gtksourceview)
("harfbuzz" ,harfbuzz)
("libepoxy" ,libepoxy)
("libmusicbrainz" ,libmusicbrainz)
@@ -1623,8 +1623,8 @@ sharing to the masses.")
("neon" ,neon)
("webkitgtk" ,webkitgtk)))
(synopsis "File previewer for the GNOME desktop")
- (description "Sushi is a DBus-activated service that allows applications to
-preview files on the GNOME desktop.")
+ (description "Sushi is a DBus-activated service that allows applications
+to preview files on the GNOME desktop.")
(home-page "https://gitlab.gnome.org/GNOME/sushi")
(license license:gpl2+)))