aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-28 10:17:55 +0100
committerLudovic Courtès <ludo@gnu.org>2014-10-28 10:17:55 +0100
commitf15615b11954dd7c5e4366fc615a1eee62e0ee57 (patch)
treedeb2d815e1fbd3a665bbc5d88198a53518975454
parent77b0ac905d461cee8585d00a0b82caacc99780ad (diff)
downloadguix-f15615b11954dd7c5e4366fc615a1eee62e0ee57.tar
guix-f15615b11954dd7c5e4366fc615a1eee62e0ee57.tar.gz
gnu: atlas: Make it non-substitutable.
Suggested by Federico Beffa <beffa@ieee.org>. * gnu/packages/maths.scm (atlas)[arguments]: Pass #:substitutable? #f. [description]: Adjust accordingly.
-rw-r--r--gnu/packages/maths.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 10f26698bc..1aa3757ebe 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -956,6 +956,13 @@ point numbers")
(arguments
`(#:parallel-build? #f
#:parallel-tests? #f
+
+ ;; ATLAS tunes itself for the machine it is built on, as explained at
+ ;; <http://lists.gnu.org/archive/html/guix-devel/2014-10/msg00305.html>.
+ ;; For this reason, we want users to build it locally instead of using
+ ;; substitutes.
+ #:substitutable? #f
+
#:modules ((srfi srfi-26)
(srfi srfi-1)
(guix build gnu-build-system)
@@ -1037,15 +1044,11 @@ point numbers")
providing C and Fortran77 interfaces to a portably efficient BLAS
implementation, as well as a few routines from LAPACK.
-Optimization occurs at build time. For this reason you should build the
-library on the maschine on which you will use it. The package must therefore
-be installed without making use of substitutes. This can be achieved with the
-following command:
-
-\"guix package --no-substitutes -i atlas\"
+Optimization occurs at build time. For this reason, the library is built on
+the machine where it is installed, without resorting to pre-built substitutes.
-In addition, before building the library, CPU throttling should be disabled.
-This can be done in the BIOS, or, on Linux, with the following commands:
+Before building the library, CPU throttling should be disabled. This can be
+done in the BIOS, or, on GNU/Linux, with the following commands:
cpufreq-selector -g performance -c 0
...