aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-29 20:47:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 22:23:21 +0100
commitf0462a38da67e911c3b86327b140d535ee70f459 (patch)
tree71f18162a63a2e1ae32550ff80569b92eb074a6c
parent8c8fb5c878b0efc02dc92e31e90d40fc4d850937 (diff)
downloadguix-f0462a38da67e911c3b86327b140d535ee70f459.tar
guix-f0462a38da67e911c3b86327b140d535ee70f459.tar.gz
gnu: Add go-github-com-adrg-xdg.
* gnu/packages/golang-xyz.scm (go-github-com-adrg-xdg): New variable. Change-Id: I6a7576d45c84e864d6db915784e32606b1008710
-rw-r--r--gnu/packages/golang-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ae3eda6936..7b92ef052f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -316,6 +316,46 @@ substitution.")
similarity as well as other string utility functions.")
(license license:expat)))
+(define-public go-github-com-adrg-xdg
+ (package
+ (name "go-github-com-adrg-xdg")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/adrg/xdg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xbkb8wmr6phj2ppr75akc58jdzrv20gc3mkxa1mmb968isy8s6c"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/adrg/xdg"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Tests need HOME to be set: could not create any of the following
+ ;; paths: /homeless-shelter/.local/data,
+ ;; /homeless-shelter/.local/data, /usr/share
+ (add-before 'check 'set-home
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-golang-org-x-sys))
+ (home-page "https://github.com/adrg/xdg")
+ (synopsis "XDG specification implementation for Golang")
+ (description
+ "Package xdg provides an implementation of the @acronym{XDG, X Desktop
+Group} Base Directory Specification. The specification defines a set of
+standard paths for storing application files including data and configuration
+files. For portability and flexibility reasons, applications should use the
+XDG defined locations instead of hardcoding paths. The package also includes
+the locations of well known user directories.")
+ (license license:expat)))
+
(define-public go-github-com-alecthomas-chroma
(package
(name "go-github-com-alecthomas-chroma")