aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-30 23:03:25 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-31 10:43:59 +0800
commitec1dffc2c13fbcef821504be9be469fc9ee42659 (patch)
tree34a6a7c9b1c13e3ff47981e2f6a020f9a2e30317
parent142be256d43bb596c328cfe4038d5f8528842467 (diff)
downloadguix-ec1dffc2c13fbcef821504be9be469fc9ee42659.tar
guix-ec1dffc2c13fbcef821504be9be469fc9ee42659.tar.gz
gnu: boolector: Fix build.
gnu/packages/maths.scm (boolector)[inputs]: Add gmp. Change-Id: I008360baed99d02d55bff76d683136ff505e2742
-rw-r--r--gnu/packages/maths.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a1c0f8e572..bb6c1648b5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -7672,7 +7672,8 @@ find_package(louvain_communities)")
(substitute* (find-files "." "\\.c$")
(("\"btor2parser/btor2parser\\.h\"") "<btor2parser.h>")))))))
(inputs (list btor2tools
- boost cryptominisat louvain-community sqlite))
+ boost cryptominisat louvain-community sqlite
+ gmp))
(native-inputs (list googletest pkg-config python-wrapper))
(home-page "https://boolector.github.io")
(synopsis "Bitvector-based theory solver")