aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-05-30 11:06:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-05-30 11:35:13 -0400
commiteb4dc1b9ae3779419b047e2f4c7b5879353956a6 (patch)
tree256cbc34b7ac4814ea98247b7f34b96b73095639
parent09690a2b0c16df874600c5ded901c3cdee805093 (diff)
downloadguix-eb4dc1b9ae3779419b047e2f4c7b5879353956a6.tar
guix-eb4dc1b9ae3779419b047e2f4c7b5879353956a6.tar.gz
gnu: patch: Fix indentation.
* gnu/packages/base.scm (patch): Re-indent package. Change-Id: I97a5d8054ebacc779bead6093d150c44acdcc91c
-rw-r--r--gnu/packages/base.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 1213aa5b20..bbe5b8cf57 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -263,7 +263,7 @@ standard utility.")
(define-public patch
(package
- (name "patch")
+ (name "patch")
(version "2.7.6")
(source (origin
(method url-fetch)
@@ -273,23 +273,23 @@ standard utility.")
(base32
"1zfqy4rdcy279vwn2z1kbv19dcfw25d2aqy9nzvdkq5bjzd0nqdc"))
(patches (search-patches "patch-hurd-path-max.patch"))))
- (build-system gnu-build-system)
- (arguments
- ;; Work around a cross-compilation bug whereby libpatch.a would provide
- ;; '__mktime_internal', which conflicts with the one in libc.a.
- (if (%current-target-system)
- `(#:configure-flags '("gl_cv_func_working_mktime=yes"))
- '()))
- (native-inputs (list ed))
- (synopsis "Apply differences to originals, with optional backups")
- (description
- "Patch is a program that applies changes to files based on differences
+ (build-system gnu-build-system)
+ (arguments
+ ;; Work around a cross-compilation bug whereby libpatch.a would provide
+ ;; '__mktime_internal', which conflicts with the one in libc.a.
+ (if (%current-target-system)
+ `(#:configure-flags '("gl_cv_func_working_mktime=yes"))
+ '()))
+ (native-inputs (list ed))
+ (synopsis "Apply differences to originals, with optional backups")
+ (description
+ "Patch is a program that applies changes to files based on differences
laid out as by the program \"diff\". The changes may be applied to one or more
files depending on the contents of the diff file. It accepts several
different diff formats. It may also be used to revert previously applied
differences.")
- (license gpl3+)
- (home-page "https://savannah.gnu.org/projects/patch/")))
+ (license gpl3+)
+ (home-page "https://savannah.gnu.org/projects/patch/")))
(define-public diffutils
(package