aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kwiecinski <piokwiecinski@gmail.com>2023-08-15 11:19:03 +0200
committerHilton Chain <hako@ultrarare.space>2023-08-27 11:41:11 +0800
commite9bea73e2da021cfccfb5356d378f2feb668742c (patch)
tree4d9f22e0ba838b882992890b767c819273333e8e
parent262efbf9b1bc3d589501d7291d5373a57c04c81b (diff)
downloadguix-e9bea73e2da021cfccfb5356d378f2feb668742c.tar
guix-e9bea73e2da021cfccfb5356d378f2feb668742c.tar.gz
gnu: emacs-orderless: Update to 1.0.
* gnu/packages/emacs-xyz.scm (emacs-orderless): Update to 1.0, previously used commit was pointing to 0.8. Signed-off-by: Hilton Chain <hako@ultrarare.space>
-rw-r--r--gnu/packages/emacs-xyz.scm57
1 files changed, 28 insertions, 29 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d2bb63674..6ab60d5e33 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11290,39 +11290,38 @@ interface.")
(license license:expat)))
(define-public emacs-orderless
- (let ((commit "004cee6b8e01f8eb0cb1c683d0a637b14890600f"))
- (package
- (name "emacs-orderless")
- (version "1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/oantolin/orderless")
- (commit commit)))
- (sha256
- (base32 "115bwqi2yc44bgvcl7lha8p2s6jgh5hksn4wa9s0kpfxhi14jwmy"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'makeinfo
- (lambda _
- (invoke "makeinfo" "orderless.texi")
- (install-file "orderless.info"
- (string-append #$output "/share/info")))))))
- (native-inputs
- (list texinfo))
- (home-page "https://github.com/oantolin/orderless")
- (synopsis "Emacs completion style that matches multiple regexps in any order")
- (description "This package provides an orderless completion style that
+ (package
+ (name "emacs-orderless")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oantolin/orderless")
+ (commit version)))
+ (sha256
+ (base32 "1jmwyici90v82gqjq44n0scrwhmg05pi9yplkn4bpss80c83dxp4"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'makeinfo
+ (lambda _
+ (invoke "makeinfo" "orderless.texi")
+ (install-file "orderless.info"
+ (string-append #$output "/share/info")))))))
+ (native-inputs
+ (list texinfo))
+ (home-page "https://github.com/oantolin/orderless")
+ (synopsis "Emacs completion style that matches multiple regexps in any order")
+ (description "This package provides an orderless completion style that
divides the pattern into space-separated components, and matches candidates
that match all of the components in any order. Each component can match in
any one of several ways: literally, as a regexp, as an initialism, in the flex
style, or as multiple word prefixes.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-consult
(package