aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-10-13 09:06:28 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-10-22 00:06:14 +0300
commite8a3f50fb0edfe61abe180544dbc4789884337d5 (patch)
treee0a2391097cbf5e1e83ab2da0572c5f151ccda6f
parent59b2a60d0041882d732e1766e28f0df5a1ef1ac1 (diff)
downloadguix-e8a3f50fb0edfe61abe180544dbc4789884337d5.tar
guix-e8a3f50fb0edfe61abe180544dbc4789884337d5.tar.gz
gnu: xdot: Update to 1.4.
* gnu/packages/graphviz.scm (xdot): Update to 1.4. [native-inputs]: Add python-packaging. Change-Id: Ifc06ab8fddfd23d0273d134efec610750bf2a462
-rw-r--r--gnu/packages/graphviz.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 18f4fc147d..a1626d3c58 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -277,7 +277,7 @@ Graphviz and LaTeX.")
(define-public xdot
(package
(name "xdot")
- (version "1.3")
+ (version "1.4")
(source
(origin
;; PyPI tarball is missing some test files.
@@ -287,7 +287,7 @@ Graphviz and LaTeX.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "00j147183yf6wp1rnlp26vvsnsz5v56qgffdpd2ijkpvphvyyiyi"))))
+ (base32 "1l34ahvcz90j3j7aspp9wqvxpq10mzgq7l0sanrj142ihdnbahvy"))))
(build-system python-build-system)
(arguments
(list
@@ -329,7 +329,8 @@ Graphviz and LaTeX.")
(when tests?
(add-installed-pythonpath inputs outputs)
(invoke "python" "test.py")))))))
- (native-inputs (list gobject-introspection xorg-server-for-tests))
+ (native-inputs (list gobject-introspection xorg-server-for-tests
+ python-packaging))
(inputs (list at-spi2-core
bash-minimal
(librsvg-for-system)