aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2017-08-03 21:03:41 +0800
committerArun Isaac <arunisaac@systemreboot.net>2017-08-05 18:48:54 +0530
commite78e38a4bb341b33f91afa7a8efa421be2d74905 (patch)
treebc90d7ac60439f6ba126a643fedbb584032c55ce
parent7f171fdaadb15bb1b313b25e9be3d1988b0f650f (diff)
downloadguix-e78e38a4bb341b33f91afa7a8efa421be2d74905.tar
guix-e78e38a4bb341b33f91afa7a8efa421be2d74905.tar.gz
gnu: emacs-exwm: Update to 0.15.
* gnu/packages/emacs.scm (emacs-exwm): Update to 0.15. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/emacs.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 917c511f32..9beb7ae62e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4631,7 +4631,7 @@ It should enable you to implement low-level X11 applications.")
(define-public emacs-exwm
(package
(name "emacs-exwm")
- (version "0.14")
+ (version "0.15")
(synopsis "Emacs X window manager")
(source (origin
(method url-fetch)
@@ -4639,7 +4639,7 @@ It should enable you to implement low-level X11 applications.")
version ".tar"))
(sha256
(base32
- "14hjjpbasm84p54fxy73fg7g1fdwqkvisdw8dwwgzkflmd647mkx"))))
+ "1y7nqry9y0a99bsdqkk9f554vczfw4sz6raadw3138835qy697jg"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-xelb" ,emacs-xelb)))
@@ -4673,12 +4673,9 @@ It should enable you to implement low-level X11 applications.")
TryExec=~@*~a~@
Type=Application~%" ,name ,synopsis exwm-executable)))
;; Add a shell wrapper to bin
- ;; Set DISPLAY variable to work around
- ;; https://github.com/ch11ng/exwm/issues/213
(with-output-to-file exwm-executable
(lambda _
(format #t "#!~a ~@
- export DISPLAY=:0 ~@
~a +SI:localuser:$USER ~@
exec ~a --exit-with-session ~a \"$@\" --eval '~s' ~%"
(string-append (assoc-ref inputs "bash") "/bin/sh")