aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves via Guix-patches via <guix-patches@gnu.org>2024-02-18 15:33:08 +0100
committerHilton Chain <hako@ultrarare.space>2024-02-25 00:04:02 +0800
commite3e64acdb8ea8a9b55e376595b0fb1018e170376 (patch)
tree9418361c240d82cc48e794ee107c4db2ecea7ad4
parentf861793141d04ba737438330a239165991712c03 (diff)
downloadguix-e3e64acdb8ea8a9b55e376595b0fb1018e170376.tar
guix-e3e64acdb8ea8a9b55e376595b0fb1018e170376.tar.gz
gnu: b4: Ensure git presence.
* gnu/packages/version-control.scm (b4): Ensure git presence. [arguments]<#:phases>: Add phase hardcode-git-bin. [inputs]: Add git-minimal. Change-Id: Ib2dca06009cdacc0e5ab4ab227cd30991474404c Signed-off-by: Hilton Chain <hako@ultrarare.space>
-rw-r--r--gnu/packages/version-control.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index f683bc4e0e..cef0012645 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2927,9 +2927,16 @@ email header.")
;; XXX: dnspython attempts to read /etc/resolv.conf when loading
;; resolver.py, which breaks the sanity check in dependent
;; packages. This should rather be fixed in dnspython.
- (delete 'sanity-check))))
+ (delete 'sanity-check)
+ ;; This ensures git is present when called.
+ (add-after 'unpack 'hardcode-git-bin
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (find-files "b4" "\\.py$")
+ (("\\['git'")
+ (string-append
+ "['" (search-input-file inputs "bin/git") "'"))))))))
(inputs
- (list python-dkimpy python-dnspython python-requests))
+ (list git-minimal python-dkimpy python-dnspython python-requests))
(propagated-inputs
(list patatt))
(home-page "https://git.kernel.org/pub/scm/utils/b4/b4.git")