aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-24 16:37:03 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:01:01 +0100
commite331cfa3e6c0e38a641de5ecf36e22199cd0341d (patch)
tree0bc6d88d40292a78d8f7ef8a86dace4d1def310a
parentc8e9ee9c47690327ea8cde92bb6109eaf33a5fcb (diff)
downloadguix-e331cfa3e6c0e38a641de5ecf36e22199cd0341d.tar
guix-e331cfa3e6c0e38a641de5ecf36e22199cd0341d.tar.gz
gnu: Add go-github-com-mwitkow-go-conntrack.
* gnu/packages/prometheus.scm (go-github-com-mwitkow-go-conntrack): New variable. Change-Id: I874b96a61ee116fee435e3817d84802fa48eacfe
-rw-r--r--gnu/packages/prometheus.scm48
1 files changed, 47 insertions, 1 deletions
diff --git a/gnu/packages/prometheus.scm b/gnu/packages/prometheus.scm
index 6ab034c20a..997cf4e503 100644
--- a/gnu/packages/prometheus.scm
+++ b/gnu/packages/prometheus.scm
@@ -24,7 +24,11 @@
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (gnu packages)
- #:use-module (gnu packages golang-build))
+ #:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-build)
+ #:use-module (gnu packages golang-check)
+ #:use-module (gnu packages golang-web)
+ #:use-module (gnu packages golang-xyz))
;;; Commentary:
;;;
@@ -39,6 +43,48 @@
;;; Libraries:
;;;
+(define-public go-github-com-mwitkow-go-conntrack
+ (package
+ (name "go-github-com-mwitkow-go-conntrack")
+ (version "0.0.0-20190716064945-2f068394615f")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mwitkow/go-conntrack")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ymjmy12ks7smgwmrwsa5kf07d9w5kpk1dn650azlzr61b561aw7"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:import-path "github.com/mwitkow/go-conntrack"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Breaking cycle:
+ ;; go-github-com-prometheus-common ->
+ ;; go-github-com-prometheus-client-golang ->
+ ;; go-github-com-mwitkow-go-conntrack ->
+ ;; go-github-com-prometheus-common
+ (delete 'build))))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-jpillora-backoff
+ go-github-com-munnerz-goautoneg
+ ;; go-github-com-prometheus-client-golang
+ go-golang-org-x-net))
+ (home-page "https://github.com/mwitkow/go-conntrack")
+ (synopsis "Go middleware for @code{net.Conn} tracking")
+ (description
+ "@url{https://prometheus.io/,Prometheus} monitoring and
+@url{https://godoc.org/golang.org/x/net/trace#@code{EventLog,(code}
+x/net/trace)} tracing wrappers @code{net.Conn}, both inbound
+(@@code{net.Listener}) and outbound (@@code{net.Dialer}).")
+ (license license:asl2.0)))
+
(define-public go-github-com-prometheus-client-model
(package
(name "go-github-com-prometheus-client-model")