aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-18 12:01:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:43:15 +0300
commite30ce5e420ac6779b5b47875bc76080abfa1c92c (patch)
tree1a3db6baed90060d336c7164a11752cc27e0a4a9
parent0cdf9eab45a8d1827b4deebce878c666547c2ded (diff)
downloadguix-e30ce5e420ac6779b5b47875bc76080abfa1c92c.tar
guix-e30ce5e420ac6779b5b47875bc76080abfa1c92c.tar.gz
gnu: Add rust-inlinable-string-0.1.
* gnu/packages/crates-io.scm (rust-inlinable-string-0.1): New variable. Change-Id: If1869320ee72ecca86f8803e1d75b14ed5789987
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c33f2ffaa5..56b394940c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31990,6 +31990,31 @@ deordinalize, demodulize, foreign key, and pluralize/singularize are supported
as both traits and pure functions acting on String types.")
(license license:bsd-2)))
+(define-public rust-inlinable-string-0.1
+ (package
+ (name "rust-inlinable-string")
+ (version "0.1.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "inlinable_string" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1ysjci8yfvxgf51z0ny2nnwhxrclhmb3vbngin8v4bznhr3ybyn8"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-serde" ,rust-serde-1))
+ #:cargo-development-inputs (("rust-serde-test" ,rust-serde-test-1))))
+ (home-page "https://github.com/fitzgen/inlinable_string")
+ (synopsis "Crate which provides the `InlinableString` type")
+ (description
+ "The @code{inlinable_string} crate provides the @code{InlinableString} type
+-- an owned, grow-able UTF-8 string that stores small strings inline and avoids
+heap-allocation -- and the @code{StringExt} trait which abstracts string
+operations over both @code{std::string::String} and @code{InlinableString} (or
+even your own custom string type).")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-inline-c-0.1
(package
(name "rust-inline-c")