aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-07-17 15:22:57 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-07-17 15:22:57 +0200
commite28a824f0899a3291bdbe35f68f123171c959dd4 (patch)
tree12493e6442ae286511e4b68125976346fa1522fc
parent17666c090b6329bf0be3bb068382d9cd4aafab01 (diff)
downloadguix-e28a824f0899a3291bdbe35f68f123171c959dd4.tar
guix-e28a824f0899a3291bdbe35f68f123171c959dd4.tar.gz
gnu: rust: Use search-patches instead of map search-patch
* gnu/packages/rust.scm: Replace instances of map search-patch with search-patches.
-rw-r--r--gnu/packages/rust.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index b0ad992138..a807978917 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -227,7 +227,7 @@ safety and thread safety guarantees.")
(sha256 (base32 "0l8c14qsf42rmkqy92ahij4vf356dbyspxcips1aswpvad81y8qm"))
(modules '((guix build utils)))
(snippet '(begin (delete-file-recursively "src/llvm") #t))
- (patches (map search-patch '("rust-1.19-mrustc.patch")))))
+ (patches (search-patches "rust-1.19-mrustc.patch"))))
(outputs '("out" "cargo"))
(properties '((timeout . 72000) ;20 hours
(max-silent-time . 18000))) ;5 hours (for armel)
@@ -718,8 +718,8 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(delete-file-recursively "src/llvm")
(delete-file-recursively "src/llvm-emscripten")
#t))
- (patches (map search-patch
- '("rust-1.25-accept-more-detailed-gdb-lines.patch")))))
+ (patches (search-patches
+ "rust-1.25-accept-more-detailed-gdb-lines.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments base-rust)
((#:phases phases)
@@ -753,9 +753,9 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(source
(origin
(inherit (package-source base-rust))
- (patches (map search-patch
- '("rust-coresimd-doctest.patch"
- "rust-1.25-accept-more-detailed-gdb-lines.patch")))))
+ (patches (search-patches
+ "rust-coresimd-doctest.patch"
+ "rust-1.25-accept-more-detailed-gdb-lines.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments base-rust)
((#:phases phases)
@@ -823,10 +823,10 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(source
(origin
(inherit (package-source base-rust))
- (patches (map search-patch '("rust-coresimd-doctest.patch"
- "rust-bootstrap-stage0-test.patch"
- "rust-1.25-accept-more-detailed-gdb-lines.patch"
- "rust-reproducible-builds.patch")))))
+ (patches (search-patches "rust-coresimd-doctest.patch"
+ "rust-bootstrap-stage0-test.patch"
+ "rust-1.25-accept-more-detailed-gdb-lines.patch"
+ "rust-reproducible-builds.patch"))))
(native-inputs
;; FIXME: Rust 1.27 and some later versions require GDB 8.2 specifically.
;; See <https://bugs.gnu.org/37810>.
@@ -859,10 +859,10 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(source
(origin
(inherit (package-source base-rust))
- (patches (map search-patch '("rust-coresimd-doctest.patch"
- "rust-bootstrap-stage0-test.patch"
- "rust-1.25-accept-more-detailed-gdb-lines.patch"
- "rust-reproducible-builds.patch")))))
+ (patches (search-patches "rust-coresimd-doctest.patch"
+ "rust-bootstrap-stage0-test.patch"
+ "rust-1.25-accept-more-detailed-gdb-lines.patch"
+ "rust-reproducible-builds.patch"))))
(inputs
;; Use LLVM 6.0
(alist-replace "llvm" (list llvm-6)
@@ -895,8 +895,8 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(source
(origin
(inherit (package-source base-rust))
- (patches (map search-patch '("rust-1.25-accept-more-detailed-gdb-lines.patch"
- "rust-reproducible-builds.patch"))))))))
+ (patches (search-patches "rust-1.25-accept-more-detailed-gdb-lines.patch"
+ "rust-reproducible-builds.patch")))))))
(define-public rust-1.30
(let ((base-rust
@@ -1010,7 +1010,7 @@ move around."
(delete-file-recursively "src/tools/lldb")
(delete-file-recursively "vendor/jemalloc-sys/jemalloc")
#t))
- (patches (map search-patch '("rust-reproducible-builds.patch")))
+ (patches (search-patches "rust-reproducible-builds.patch"))
;; the vendor directory has moved to the root of
;; the tarball, so we have to strip an extra prefix
(patch-flags '("-p2"))))