aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-07 13:27:09 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-07 14:53:24 +0100
commite07a44891cd906aa071e88e355b9cc8f93b047f7 (patch)
tree9de455782949e6af5b1807cf00c1255a49c72ce5
parent8e933cb36aa08843fd0187ec4c441179a1ed3695 (diff)
downloadguix-e07a44891cd906aa071e88e355b9cc8f93b047f7.tar
guix-e07a44891cd906aa071e88e355b9cc8f93b047f7.tar.gz
gnu: Add gtksourceviewmm.
* gnu/packages/gtk.scm (gtksourceviewmm): New public variable.
-rw-r--r--gnu/packages/gtk.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a1d7e548aa..a96cb96470 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1122,6 +1122,38 @@ extensive documentation, including API reference and a tutorial.")
("gtk+" ,gtk+-2)
("glibmm" ,glibmm)))))
+(define-public gtksourceviewmm
+ (package
+ (name "gtksourceviewmm")
+ (version "3.18.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32 "0fgvmhm4h4qmxig87qvangs6ijw53mi40siz7pixlxbrsgiil22i"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ ;; In 'Requires' of gtksourceviewmm-3.0.pc.
+ `(("glibmm" ,glibmm)
+ ("gtkmm" ,gtkmm)
+ ("gtksourceview" ,gtksourceview)))
+ (synopsis "C++ interface to the GTK+ 'GtkTextView' widget")
+ (description
+ "gtksourceviewmm is a portable C++ library that extends the standard GTK+
+framework for multiline text editing with support for configurable syntax
+highlighting, unlimited undo/redo, search and replace, a completion framework,
+printing and other features typical of a source code editor.")
+ (license license:lgpl2.1+)
+ (home-page "https://developer.gnome.org/gtksourceview/")))
+
+;;;
+;;; Python bindings.
+;;;
+
(define-public python-pycairo
(package
(name "python-pycairo")