aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:15:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:37 +0200
commitdd53cac90eeea23df5829ff8260103941a9573d7 (patch)
treedad336f8d3d7572d459f8d5eaa3bfe2304312a9c
parent4ea050858f9d059b8e0bcb47c9ddb2a40ccd1f55 (diff)
downloadguix-dd53cac90eeea23df5829ff8260103941a9573d7.tar
guix-dd53cac90eeea23df5829ff8260103941a9573d7.tar.gz
gnu: Add texlive-spelling.
* gnu/packages/tex.scm (texlive-spelling): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 98481761b3..6554ee9e30 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13901,6 +13901,28 @@ non-breaking small spaces, where both hyphenation and kerning against space
are correctly applied. Additionally, interword kerning can be applied.")
(license license:lppl1.3c)))
+(define-public texlive-spelling
+ (package
+ (name "texlive-spelling")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/spelling/" "scripts/spelling/"
+ "tex/luatex/spelling/")
+ (base32
+ "1pg4jz1rxpjc9648b53zbnwrn59id9iv8b1jfwl6nqj58q285w7q")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/spelling")
+ (synopsis "Support for spell-checking of LuaTeX documents")
+ (description
+ "The package aids spell-checking of TeX documents compiled with the
+LuaTeX engine. It can give visual feedback in PDF output similar to WYSIWYG
+word processors. The package relies on an external spell-checker application
+to check spelling of a text file and to output a list of bad spellings. The
+package should work with most spell-checkers, even dumb, TeX-unaware ones.")
+ (license license:lppl1.3+)))
+
(define-public texlive-standalone
(package
(name "texlive-standalone")