aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-06-18 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-06-18 02:00:08 +0200
commitdcca13ed7340f17a33a4c0907c13b64d5da66a8e (patch)
tree155a415bfec93d4884824bea90cad8cb593ca906
parent65ed7a61f1ad01da440f0e7e08bfc32b43deed73 (diff)
downloadguix-dcca13ed7340f17a33a4c0907c13b64d5da66a8e.tar
guix-dcca13ed7340f17a33a4c0907c13b64d5da66a8e.tar.gz
gnu: opensmtpd: Update to 7.3.0p0.
* gnu/packages/mail.scm (opensmtpd): Update to 7.3.0p0. [arguments]: Remove obsolete 'fix-smtpctl-encrypt-bug phase. Don't explicitly return #t from remaining phases.
-rw-r--r--gnu/packages/mail.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index d098b3f268..801555803a 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -3175,14 +3175,14 @@ from the Cyrus IMAP project.")
(define-public opensmtpd
(package
(name "opensmtpd")
- (version "6.8.0p2")
+ (version "7.3.0p0")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.opensmtpd.org/archives/"
"opensmtpd-" version ".tar.gz"))
(sha256
- (base32 "05sd7bmq29ibnqbl2z53hiyprfxzf0qydfdaixs68rz55wqhbgsi"))))
+ (base32 "1rnaa022pkdc15vkvlisv42dvcxchib40h0m97myfyqjralabmrd"))))
(build-system gnu-build-system)
(inputs
(list bdb
@@ -3205,13 +3205,6 @@ from the Cyrus IMAP project.")
"--with-table-db")
#:phases
(modify-phases %standard-phases
- ;; See: https://github.com/OpenSMTPD/OpenSMTPD/issues/1069.
- (add-after 'unpack 'fix-smtpctl-encrypt-bug
- (lambda _
- (substitute* "usr.sbin/smtpd/smtpctl.c"
- (("\"encrypt\", \"--\",")
- "\"encrypt\","))
- #t))
;; Fix some incorrectly hard-coded external tool file names.
(add-after 'unpack 'patch-FHS-file-names
(lambda _
@@ -3219,8 +3212,7 @@ from the Cyrus IMAP project.")
;; ‘gzcat’ is auto-detected at compile time, but ‘cat’ isn't.
(("/bin/cat") (which "cat")))
(substitute* "usr.sbin/smtpd/mda_unpriv.c"
- (("/bin/sh") (which "sh")))
- #t))
+ (("/bin/sh") (which "sh")))))
;; OpenSMTPD provides a single smtpctl utility to control both the
;; daemon and the local submission subsystem. To accomodate systems
;; that require historical interfaces such as sendmail, newaliases or
@@ -3233,8 +3225,7 @@ from the Cyrus IMAP project.")
(for-each (lambda (command)
(symlink "smtpctl" (string-append sbin command)))
(list "mailq" "makemap" "newaliases"
- "send-mail" "sendmail")))
- #t)))))
+ "send-mail" "sendmail"))))))))
(synopsis "Lightweight SMTP daemon")
(description
"OpenSMTPD is an implementation of server-side @acronym{SMTP, Simple Mail