aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-20 16:37:01 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:00:59 +0100
commitd7f4f2c0538cdacf088f0108558c70656f96b4c2 (patch)
tree3c41708a40a7fbb2caf9479a03c33f928eebcf46
parentd43795cd208161495391104054e36abb94ea0a89 (diff)
downloadguix-d7f4f2c0538cdacf088f0108558c70656f96b4c2.tar
guix-d7f4f2c0538cdacf088f0108558c70656f96b4c2.tar.gz
gnu: go-github-com-stretchr-testify: Update to 1.9.0.
* gnu/packages/golang-check.scm (go-github-com-stretchr-testify): Update to 1.9.0. (go-github-com-stretchr-testify-next): Delete variable. (go-go-uber-org-goleak): [native-inputs]: Remove go-github-com-stretchr-testify-next; add go-github-com-stretchr-testify. * gnu/packages/golang-web.scm (go-github-com-quic-go-webtransport-go): [native-inputs]: Remove go-github-com-stretchr-testify-next; add go-github-com-stretchr-testify. * gnu/packages/golang-xyz.scm (go-github-com-masterminds-semver-v3, go-go-uber-org-dig, go-go-uber-org-fx, go-go-uber-org-zap): [native-inputs]: Remove go-github-com-stretchr-testify-next; add go-github-com-stretchr-testify. Change-Id: Ife39309254b5d89fcb61d84183771a4aab7e13db
-rw-r--r--gnu/packages/golang-check.scm21
-rw-r--r--gnu/packages/golang-web.scm2
-rw-r--r--gnu/packages/golang-xyz.scm8
3 files changed, 8 insertions, 23 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 4323a6c557..6baffb84d2 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -878,7 +878,7 @@ current goroutine's ID.")
(define-public go-github-com-stretchr-testify
(package
(name "go-github-com-stretchr-testify")
- (version "1.7.0")
+ (version "1.9.0")
(source
(origin
(method git-fetch)
@@ -888,7 +888,7 @@ current goroutine's ID.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ixgjsvafr3513pz3r6pmgk074s2dxkll0dadvl25gkf30rkmh10"))))
+ "12cnhk96h8b3ddlb7jfvwwavzc0j1c2iva92pszl9rv6r571ckzg"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/stretchr/testify"))
@@ -923,21 +923,6 @@ Features include:
(propagated-inputs
(list go-gopkg-in-yaml-v3)))))
-(define-public go-github-com-stretchr-testify-next
- (package
- (inherit go-github-com-stretchr-testify)
- (name "go-github-com-stretchr-testify")
- (version "1.9.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stretchr/testify")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "12cnhk96h8b3ddlb7jfvwwavzc0j1c2iva92pszl9rv6r571ckzg"))))))
-
(define-public go-github-com-tdewolff-test
(package
(name "go-github-com-tdewolff-test")
@@ -1280,7 +1265,7 @@ gracefully enhance standard library testing package and behaviors of the
(list
#:import-path "go.uber.org/goleak"))
(native-inputs
- (list go-github-com-stretchr-testify-next))
+ (list go-github-com-stretchr-testify))
(home-page "https://pkg.go.dev/go.uber.org/goleak")
(synopsis "Goroutine leak detector")
(description
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index f8862ddd10..2b72cb3423 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2786,7 +2786,7 @@ protocol.")
#:import-path "github.com/quic-go/webtransport-go"))
(native-inputs
(list go-go-uber-org-mock
- go-github-com-stretchr-testify-next))
+ go-github-com-stretchr-testify))
(propagated-inputs
(list go-github-com-quic-go-quic-go
go-golang-org-x-exp))
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ebce00f117..cf29278501 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3111,7 +3111,7 @@ implementing features like:
(list
#:import-path "github.com/Masterminds/semver/v3"))
(native-inputs
- (list go-github-com-stretchr-testify-next))
+ (list go-github-com-stretchr-testify))
(home-page "https://github.com/Masterminds/semver/")
(synopsis "@code{semver} helps to work with semantic versions")
(description
@@ -5158,7 +5158,7 @@ CPU quota.")
(list
#:import-path "go.uber.org/dig"))
(native-inputs
- (list go-github-com-stretchr-testify-next))
+ (list go-github-com-stretchr-testify))
(home-page "https://pkg.go.dev/go.uber.org/dig")
(synopsis "Reflection based dependency injection toolkit for Golang")
(description
@@ -5184,7 +5184,7 @@ object dependencies graph during the process startup.")
(list
#:import-path "go.uber.org/fx"))
(native-inputs
- (list go-github-com-stretchr-testify-next))
+ (list go-github-com-stretchr-testify))
(propagated-inputs
(list go-go-uber-org-dig
go-go-uber-org-goleak
@@ -5252,7 +5252,7 @@ applications out of reusable, composable modules.")
(string-append "src/" import-path
"/stacktrace_ext_test.go")))))))
(native-inputs
- (list go-github-com-stretchr-testify-next
+ (list go-github-com-stretchr-testify
go-go-uber-org-goleak
go-golang-org-x-lint
go-honnef-co-go-tools))