aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-05 21:24:10 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-05 21:24:10 +0100
commitd6c95d4208a0cbc3ab742732865f9481c637660f (patch)
treee0dcafbdee037b2a45d51851a31f19b2cea3e700
parentb2dbd7ca8a9285ffd25c1bf089b0ffac28913997 (diff)
downloadguix-d6c95d4208a0cbc3ab742732865f9481c637660f.tar
guix-d6c95d4208a0cbc3ab742732865f9481c637660f.tar.gz
gnu: Revmoe go-github-com-syndtr-goleveldb.
This package is a duplicate to go-github-com-syndtr-goleveldb-leveldb. * gnu/packages/ipfs.scm: Revmoe (gnu packages syncthing) module. (kubo) [inputs]: Replace go-github-com-syndtr-goleveldb with go-github-com-syndtr-goleveldb-leveldb. * gnu/packages/syncthing.scm (go-github-com-syndtr-goleveldb): Remove variable. Change-Id: I8641a18a3d97f570f3bbbd849f7dabdea4e41b01
-rw-r--r--gnu/packages/ipfs.scm5
-rw-r--r--gnu/packages/syncthing.scm28
2 files changed, 2 insertions, 31 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index ac832dcd52..f06dc402a4 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -36,8 +36,7 @@
#:use-module (gnu packages golang-web)
#:use-module (gnu packages golang-xyz)
#:use-module (gnu packages python)
- #:use-module (gnu packages shells)
- #:use-module (gnu packages syncthing))
+ #:use-module (gnu packages shells))
(define-public go-github-com-ipfs-go-cid
(package
@@ -405,7 +404,7 @@ written in Go.")
go-github-com-pkg-errors
go-github-com-prometheus-client-golang
go-github-com-stretchr-testify
- go-github-com-syndtr-goleveldb
+ go-github-com-syndtr-goleveldb-leveldb
;;go-github-com-tidwall-gjson
;;go-github-com-tidwall-sjson
go-github-com-whyrusleeping-go-sysinfo
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 43199d4ad6..6672edd5ea 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -427,34 +427,6 @@ run-time in Go.")
(home-page "https://github.com/sasha-s/go-deadlock")
(license asl2.0)))
-(define-public go-github-com-syndtr-goleveldb
- (let ((commit "758128399b1df3a87e92df6c26c1d2063da8fabe")
- (revision "4"))
- (package
- (name "go-github-com-syndtr-goleveldb")
- (version (git-version "1.0.1" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/syndtr/goleveldb")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0mnkzrz4di13g6ggd54my7bkb9nwk8f5k672dyasn467wsg7bf8f"))))
- (build-system go-build-system)
- (propagated-inputs
- (list go-github-com-golang-snappy))
- (arguments
- `(#:import-path "github.com/syndtr/goleveldb/leveldb"
- #:unpack-path "github.com/syndtr/goleveldb"
- #:tests? #f)) ; XXX needs 'github.com/onsi/gomega' package
- (synopsis "LevelDB key/value database")
- (description "This is an implementation of the LevelDB key / value
-database in Go.")
- (home-page "https://github.com/syndtr/goleveldb")
- (license bsd-2))))
-
(define-public go-github-com-thejerf-suture
(package
(name "go-github-com-thejerf-suture")