aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:43:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:15 +0200
commitd3b2d4143d7d487ae1db4cd93f533d68d3b846e1 (patch)
tree3f0bb43df86b739ec53b564b38d4d88bca54b9ae
parenta00b83b2f1c3d79a6f08b4bfce20f1d576b9c4e8 (diff)
downloadguix-d3b2d4143d7d487ae1db4cd93f533d68d3b846e1.tar
guix-d3b2d4143d7d487ae1db4cd93f533d68d3b846e1.tar.gz
gnu: Add texlive-qsharp.
* gnu/packages/tex.scm (texlive-qsharp): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e2dea613f4..aacc338b35 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5707,6 +5707,25 @@ algorithms in a natural manner.")
@code{listings} package.")
(license license:bsd-3)))
+(define-public texlive-qsharp
+ (package
+ (name "texlive-qsharp")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/qsharp/" "source/latex/qsharp/"
+ "tex/latex/qsharp/")
+ (base32
+ "104asd1z3n7yqpq2midca2sjjxbbr0c9ngaqncj8zzb0i7ky19v4")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/qsharp")
+ (synopsis "Syntax highlighting for the Q# language")
+ (description
+ "The package provides syntax highlighting for the Q# language,
+a domain-specific language for quantum programming.")
+ (license license:lppl1.3c)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")